Closed Bug 1585615 Opened 4 months ago Closed 3 months ago

The Social Tracking Protection panel is not triggered at all

Categories

(Firefox :: Protections UI, defect, P1, critical)

defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 + verified

People

(Reporter: oana.botisan, Assigned: xeonchen)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [skyline][stp])

Attachments

(1 file)

Affected versions

  • Firefox 71.0a1

Affected platforms

  • Windows 10 x64
  • Ubuntu 18.04 x64
  • macOS 10.13

Steps to reproduce

  1. Open with a clean profile a site with Social Trackers (e.g.: http://www.psimadethis.com/) in 4 different tabs.

Expected result

  • The Social Tracking Protection doorhanger is triggered.

Actual result

  • The Social Tracking Protection doorhanger is not triggered at all, no matter how many times you open a link.

Regression range

  • last good: 2019-09-10
  • first bad: 2019-09-11
  • Bug 1570631 might have caused this issue.

Additional note:

  • The Cryptominers and Fingerprinters doorhangers are displayed.
Assignee: nobody → xeonchen
Priority: -- → P1
Whiteboard: [skyline][stp]
Status: NEW → ASSIGNED

content blocking event should be checked bitwisely to see if targeted bits are all matched.

Gary, do you have an update on this patch? Will that be fixed before the final merge of 71 to beta next Monday? Thanks

Flags: needinfo?(xeonchen)

Gary is on PTO until next week. The patch is mostly ready, we need to sort out a misunderstanding about the tests though, so I'm hesitant to have anyone else take over. This should be a very painless uplift into 71. We should probably still track it to be sure.

(In reply to Pascal Chevrel:pascalc from comment #2)

Gary, do you have an update on this patch? Will that be fixed before the final merge of 71 to beta next Monday? Thanks

I'm landing this :)

Flags: needinfo?(xeonchen)
Pushed by xeonchen@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/747c5f90f2c3
check content blocking event parameter bitwisely; r=johannh
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

I verified the fix using the latest Nightly 71.0a1 on Windows 10 x64, Ubuntu 18.04 and macOS 10.13. The issue is not reproducing anymore.

Status: RESOLVED → VERIFIED
Blocks: 1590442
You need to log in before you can comment on or make changes to this bug.