Closed Bug 1585776 Opened 2 months ago Closed Last month

Failing test browser_policy_extensionsettings.js on fission

Categories

(Firefox :: Enterprise Policies, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Firefox 71
Fission Milestone M4
Tracking Status
firefox71 --- fixed

People

(Reporter: mkaply, Assigned: kmag, NeedInfo)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(1 file)

The test browser_policy_extensionsettings.js was marked as failing on fission.

The reason for the failure is that two of the tasks in the test click on a link to install an addon. Prior to fission, those linked to the addon XPI directly. With fission, they open a blank page so the test fails.

Depends on: 1574372
Priority: -- → P3
Fission Milestone: --- → M4
Assignee: nobody → kmaglione+bmo

The XPInstall content handlers currently make all sorts of assumptions about
the process they're being run in and the docShell their request is tied to.
These assumptions don't hold under Fission, either now, when they may be
called just after a process switch, or in the future, when they'll be called
in the parent process.

This patch updates them to operate on the BrowsingContext of the request, and
to do their messaging via the process message manager, rather than via frame
message managers. As a bonus, it also removes the existing hacks they had in
place to handle the cases where frame message managers didn't work.

Duplicate of this bug: 1587711
Pushed by maglione.k@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/93c2588d2799
Fix XPInstall content handler under Fission. r=nika
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Hello,

Will this fix require manual validation? If yes, please provide some steps to reproduce in order to correctly test it and also, please set the "qe-verify+" flag. Otherwise, could the "qe-verify-" flag be added? Thanks!

Flags: needinfo?(kmaglione+bmo)
You need to log in before you can comment on or make changes to this bug.