Closed Bug 1585777 Opened 4 months ago Closed 3 months ago

Make BrowserTestUtils.loadURI Fission-compatible

Categories

(Testing :: Mochitest, task, P2)

task

Tracking

(Fission Milestone:M4)

RESOLVED FIXED
Fission Milestone M4

People

(Reporter: neha, Assigned: annyG)

References

(Blocks 1 open bug)

Details

Attachments

(3 files, 1 obsolete file)

No description provided.
Assignee: nobody → agakhokidze
Status: NEW → ASSIGNED
Fission Milestone: --- → M4
Priority: -- → P2
Depends on: 1586050
Blocks: 1585681
No longer blocks: 1586189
No longer blocks: 1586190
Attachment #9100507 - Attachment is obsolete: true
Attachment #9103761 - Attachment description: Bug 1585777 - Make BrowserTestUtils.loadURI Fission-compatible, → Bug 1585777 - Part 1: Make BrowserTestUtils.loadURI Fission-compatible,

Waiting for BrowserTestUtils.browserLoaded patches to land again before I land this.

Keywords: leave-open
Pushed by agakhokidze@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8db87421134d
Part 1: Make BrowserTestUtils.loadURI Fission-compatible, r=nika
https://hg.mozilla.org/integration/autoland/rev/55724db5349e
Part 2: Fix test_url_for_process_types and its callers to be more readable, r=nika
Duplicate of this bug: 1585681
Pushed by agakhokidze@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/182daeba07e6
Part 3: Enable browser/modules/test/browser/browser_UsageTelemetry_domains.js for Fission, r=mccr8
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.