Closed Bug 1585972 Opened 2 months ago Closed Last month

Homepage cannot be changed and related add-ons fail installation if the remote settings ignore list isn't verified.

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set
Points:
2

Tracking

()

RESOLVED FIXED
mozilla71
Iteration:
71.3 - Sept 30 - Oct 13
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- fixed
firefox71 --- fixed

People

(Reporter: standard8, Assigned: standard8)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

For some reason, my main profile could not verify the "hijack-blocklists" collection from remote settings (we're investigating that elsewhere, but it could be a result of having "played around" with the collection previously).

As a result, an add-on that was setting the home page, could not set it (even though it wasn't blocked), and failed to complete its installation.

This is actually an issue in IgnoreList.jsm as it is meant to handle this situation, attempt to re-initialise, and worst case, fail gracefully with no block list. Filing under add-on manager though, as this is where the most obvious side-effect occurred.

Iteration: --- → 71.3 - Sept 30 - Oct 13
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ecc7bad16aef
If remote settings returns an invalid signature error, ignore lists should handle it correctly. r=mikedeboer
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

I was seeing this same error (Invalid content signature (main/hijack-blocklists)) on Nightly 71 when trying to change homepage in about:preferences#home on several profiles with a "bad" remote-settings database until this patch fixed it.

Fix window (this bug):
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=8d7ad5f385fe58896ba3a30c4590a68a05682885&tochange=ecc7bad16aef565a06c3910218f915a1510401c3

Beta 70 is also affected.

Summary: If the remote settings ignore list isn't verified, then it will stop add-ons completing installation → Homepage cannot be changed and related add-ons fail installation if the remote settings ignore list isn't verified.

Hello
Will this require manual validation? If yes, please set the "qe+ verify" flag and provide some steps to reproduce the intial issue (like if remote settings accessed through the remote-settings-devtools extension, how would we verify the "hijack-blocklists" collection and the add-on which was used to set the homepage but failed installation)
If there is no need for manual tests, could the "qe-verify-" flag be added?

Thanks!

Flags: needinfo?(standard8)

Comment on attachment 9098519 [details]
Bug 1585972 - If remote settings returns an invalid signature error, ignore lists should handle it correctly. r?mikedeboer

Beta/Release Uplift Approval Request

  • User impact if declined: If a user's ignore list (used for Search Engines and homepages) becomes invalid due to a signature failure, then it might not get re-synced with the server. Additionally, in that situation, the user might then not be able to properly install add-ons that override the home page.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small corrections to the algorithm for getting the ignore list and handling it when it is not valid.
  • String changes made/needed: None.
Flags: needinfo?(standard8)
Attachment #9098519 - Flags: approval-mozilla-beta?

I think the added test coverage is enough that this doesn't require manual verification (which would be quite hard to do anyway, as it involves breaking the database).

Flags: qe-verify-

Comment on attachment 9098519 [details]
Bug 1585972 - If remote settings returns an invalid signature error, ignore lists should handle it correctly. r?mikedeboer

Fix for regression in 70, has test coverage, OK for beta uplift.

Attachment #9098519 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.