Closed Bug 1586423 Opened 2 months ago Closed Last month

meet.google.com / Google Hangouts doesn't work in Nightly ("Couldn't start the video call because of an error")

Categories

(Core :: WebRTC, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 + fixed

People

(Reporter: dholbert, Assigned: jgilbert)

References

(Blocks 1 open bug, Regression, )

Details

(Keywords: regression, site-compat)

Attachments

(1 file)

STR:

  1. (optional) use a fresh Firefox profile
  2. Start a meeting at https://meet.google.com/ , or visit https://meet.google.com/jkf-gpzy-owq (a meeting I started; not sure how long it'll be active)

EXPECTED RESULTS:
Underneath the permission prompts, you should see a black video preview area and "What's your name"

ACTUAL RESULTS:
The page instead says "Couldn't start the video call because of an error". (There are still permissions prompts for my video/audio, but I'm still unable to join the meeting even after I accept these prompts with the "remember" checkbox.)

This seems to be a regression from bug 1470568.

mozregression gives me a regresssion range of https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=a4a3a37a8a9499865c7dbc8a2678154317af9dc1&tochange=2fca72b71c56c2cf8bcc736f814aa8f76ad3382d
which just includes that one bug.

Flags: needinfo?(docfaraday)

[sorry, I hit a Bugzilla bug and it lost my first-comment comments on bug-filing, grr. I'll retype them in comment 0 via "Edit" pencil-icon.]

[Tracking Requested - why for this release]: breaks a relatively-important video conferencing site

whereby.com is also broken when used with their SFU.

SfuConnectionManager: failed to create answer for offer DOMException: "Failed to parse SDP: SDP Parse Error on line 21:  Warning: Unrecognized attribute (rtcp-rsize) 
SDP Parse Error on line 40:  Warning: Unrecognized attribute (rtcp-rsize) 
SDP Parse Error on line 25: No rid attribute for 'rid=hi'
" 3ec61eca-da75-4497-90cf-a2d29deaa062

These services are using a format that has been invalid for more than 3 years (since draft-ietf-mmusic-sdp-simulcast-04), so it is about time to switch over to the new format. Who are our contacts at meet and whereby nowadays? I could maybe see reverting this change temporarily to allow more time to fix this, but it is not a very complicated fix.

Flags: needinfo?(docfaraday) → needinfo?(drno)

I've reached out to whereby, but it's unclear when they can have a fix for this.

I reached out to the Meet team. I'll update once I hear back from them.

Since we are pretty close to a train ride I think we should consider reverting the change from bug 1470568 for 71 and consider doing it at the beginning of the 72 cycle.

Flags: needinfo?(drno)

Ok. Let's see where we are next week on fixes from meet and whereby, in case they can fix their end in time.

Flags: needinfo?(docfaraday)

I suggest extending the Bug Title
from
meet.google.com doesn't work in Nightly ("Couldn't start the video call because of an error")
to
meet.google.com / Google Hangouts doesn't work in Nightly ("Couldn't start the video call because of an error")

It took me a couple of days to find this bug because I was not smart enough to use the right keyword. Hope this minor change is okay with people here.

Also, thanks to the people who are working on fixing this. You are stars!

-Henrik

Summary: meet.google.com doesn't work in Nightly ("Couldn't start the video call because of an error") → meet.google.com / Google Hangouts doesn't work in Nightly ("Couldn't start the video call because of an error")

PS: Here's my workaround: I installed a release version of Firefox and run this in parallel to Nightly to keep my Google Hangouts going until this bug is fixed.

Have we heard back from whereby and meet about this?

Flags: needinfo?(docfaraday) → needinfo?(drno)
Flags: needinfo?(apehrson)

This sucks a lot from a user perspective. Can we delay breakage until after we have traction on ensuring major application are updated?

My contact at Whereby is on leave until end of October, and no-one else there has picked this up AFAIK.

Flags: needinfo?(apehrson)
Priority: -- → P1

(In reply to Byron Campen [:bwc] from comment #10)

Have we heard back from whereby and meet about this?

The Hangouts team replied back today that they are encountering problems with Firefox when trying to handle it on their end. So I think we should revert this to prevent this riding into Beta and give services more time to adapt.

Flags: needinfo?(drno)

(In reply to Jeff Gilbert [:jgilbert] from comment #11)

This sucks a lot from a user perspective. Can we delay breakage until after we have traction on ensuring major application are updated?

In general that would be ideal. But it is completely unpredictable if and which service out there is going to have problems with our changes. Which would then mean we would have to test every single service out there before we land patches.

Did we issue deprecation warnings for sites trying to use rid= before removing the support? Doing that for a couple of versions prior (and including both deprecation and removal in the release notes for devs) seems like a best practice. At least then sites cannot come and say we didn't warn them.

We could hook a telemetry counter to the deprecation warning too, to have an idea of the damage we'll be causing.

Yeah, we have processes for use-counting to probe. It's fine to break things on accident sometimes, but we should rush to revert once we get a clear regression like this.

I've been unable to use Google Meet (which I need for work calls with other companies!) in my default browser for over a week. It's been almost two weeks without resolution, let's revert this.

Assignee: nobody → jgilbert
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/30a9a8619ce1
Revert bug 1470568 for breaking Google Meet, etc. r=bwc
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

¡Hola!

https://meet.google.com/ works again on Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0 ID:20191017093524

Should this one be linked to https://bugzilla.mozilla.org/show_bug.cgi?id=1431543 for visibility?

¡Gracias!
Alex

Status: RESOLVED → VERIFIED

Yes, thank you.

Blocks: hangouts

Whereby should be fixed now FWIW.

You need to log in before you can comment on or make changes to this bug.