Closed Bug 1586512 Opened 10 months ago Closed 10 months ago

Perma fail Tier 2 Central TEST-UNEXPECTED-PASS | chrome://reftest/content/forms/textbox/accesskey-4.xul == chrome://reftest/content/forms/textbox/accesskey-4-ref.xul | image comparison, max difference: 0, number of differing pixels: 0

Categories

(Core :: Layout: Form Controls, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: emalysz)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: btara [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=269903123&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/L1-jm97FS2iC_9J4a1v2Dg/runs/0/artifacts/public/logs/live_backing.log
Reftest URL: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/L1-jm97FS2iC_9J4a1v2Dg/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1


[task 2019-10-05T12:19:31.628Z] 12:19:31 INFO - REFTEST TEST-START | chrome://reftest/content/forms/textbox/accesskey-4.xul == chrome://reftest/content/forms/textbox/accesskey-4-ref.xul
[task 2019-10-05T12:19:31.628Z] 12:19:31 INFO - REFTEST TEST-LOAD | chrome://reftest/content/forms/textbox/accesskey-4.xul | 1607 / 1973 (81%)
[task 2019-10-05T12:19:31.628Z] 12:19:31 INFO - REFTEST TEST-LOAD | chrome://reftest/content/forms/textbox/accesskey-4-ref.xul | 1607 / 1973 (81%)
[task 2019-10-05T12:19:31.628Z] 12:19:31 INFO - REFTEST TEST-UNEXPECTED-PASS | chrome://reftest/content/forms/textbox/accesskey-4.xul == chrome://reftest/content/forms/textbox/accesskey-4-ref.xul | image comparison, max difference: 0, number of differing pixels: 0
[task 2019-10-05T12:19:31.629Z] 12:19:31 INFO - REFTEST IMAGE: [edit by dholbert: omitting data URI since it's not useful and it's also in the log]
[task 2019-10-05T12:19:31.629Z] 12:19:31 INFO - REFTEST INFO | Saved log: START chrome://reftest/content/forms/textbox/accesskey-4.xul
[task 2019-10-05T12:19:31.629Z] 12:19:31 INFO - REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering AfterOnLoadScripts
[task 2019-10-05T12:19:31.629Z] 12:19:31 INFO - REFTEST INFO | Saved log: Initializing canvas snapshot
[task 2019-10-05T12:19:31.629Z] 12:19:31 INFO - REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
[task 2019-10-05T12:19:31.629Z] 12:19:31 INFO - REFTEST INFO | Saved log: [CONTENT] RecordResult fired
[task 2019-10-05T12:19:31.629Z] 12:19:31 INFO - REFTEST INFO | Saved log: RecordResult fired
[task 2019-10-05T12:19:31.629Z] 12:19:31 INFO - REFTEST INFO | Saved log: START chrome://reftest/content/forms/textbox/accesskey-4-ref.xul
[task 2019-10-05T12:19:31.629Z] 12:19:31 INFO - REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering AfterOnLoadScripts
[task 2019-10-05T12:19:31.629Z] 12:19:31 INFO - REFTEST INFO | Saved log: Initializing canvas snapshot
[task 2019-10-05T12:19:31.629Z] 12:19:31 INFO - REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
[task 2019-10-05T12:19:31.629Z] 12:19:31 INFO - REFTEST INFO | Saved log: [CONTENT] RecordResult fired
[task 2019-10-05T12:19:31.629Z] 12:19:31 INFO - REFTEST INFO | Saved log: RecordResult fired
[task 2019-10-05T12:19:31.629Z] 12:19:31 INFO - REFTEST TEST-END | chrome://reftest/content/forms/textbox/accesskey-4.xul == chrome://reftest/content/forms/textbox/accesskey-4-ref.xul

This seems to be introduced by bug 1586336.

Flags: needinfo?(emalysz)
Flags: needinfo?(bgrinstead)
Regressed by: 1586336
Summary: Perma fail Central TEST-UNEXPECTED-PASS | chrome://reftest/content/forms/textbox/accesskey-4.xul == chrome://reftest/content/forms/textbox/accesskey-4-ref.xul | image comparison, max difference: 0, number of differing pixels: 0 → Perma fail Tier 2 Central TEST-UNEXPECTED-PASS | chrome://reftest/content/forms/textbox/accesskey-4.xul == chrome://reftest/content/forms/textbox/accesskey-4-ref.xul | image comparison, max difference: 0, number of differing pixels: 0

(In reply to Intermittent Failures Robot from comment #3)

23 failures in 4292 pushes (0.005 failures/push) were associated with this bug in the last 7 days.

Repository breakdown:

  • mozilla-central: 20
  • autoland: 3

Platform breakdown:

  • android-hw-p2-8-0-arm7-api-16-qr: 23

I would have thought this test was skipped on Android via skip-if(cocoaWidget||Android): https://searchfox.org/mozilla-central/rev/5cb522c7baba24e55874809e0e206b001494c1e9/layout/reftests/forms/textbox/reftest.list#8-9. Daniel, could you help us figure out which conditions need to change in the reftest.list now that this test seems to be passing unexpectedly on "android-hw-p2-8-0-arm7-api-16-qr"?

Flags: needinfo?(bgrinstead) → needinfo?(dholbert)
Duplicate of this bug: 1586835
Assignee: nobody → emalysz
Flags: needinfo?(emalysz)

(In reply to Brian Grinstead [:bgrins] from comment #4)

I would have thought this test was skipped on Android via skip-if(cocoaWidget||Android)

That gets superceded by the "fails-if(webrender)" later in the line. The platform here is Android WebRender, so both of these annotations match it, and I believe we trust the last one to set the behavior/expectation. So we run the test and expect it to fail.

I think Emma's patch is correct, but Try can tell us for sure.

Flags: needinfo?(dholbert)
Pushed by bgrinstead@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7046609ec00a
fix the reftest failure annotation to be more specific for Android failure r=dholbert
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
You need to log in before you can comment on or make changes to this bug.