Closed Bug 1586778 Opened 5 months ago Closed 4 months ago

Urlbar view background is transparent when ui.popup.disable_autohide is enabled

Categories

(Firefox :: Address Bar, defect, P5)

defect
Points:
1

Tracking

()

RESOLVED FIXED
Firefox 72
Iteration:
72.1 - Oct 21 - Nov 3
Tracking Status
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- disabled
firefox72 --- fixed

People

(Reporter: harry, Assigned: mak)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Screenshot of behaviour attached. The transparency appears to have been caused by bug 1586232.

We already fixed some ui.popup.autohide behaviour in bug 1575651. We should probably wait until near the end of the megabar work to fix this, when we're most confident that our layout changes will stick and we won't have to re-address this.

Priority: -- → P5
Depends on: 1589826
Summary: Urlbar view background is transparent when ui.popup.autohide is enabled → Urlbar view background is transparent when ui.popup.disable_autohide is enabled
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Iteration: --- → 72.1 - Oct 21 - Nov 3
Points: --- → 1

I'm pretty sure this is due to how the "collapsed" state works and so bug 1589826 would resolve this. I don't think this is worth spending time on in the meantime.

Improving the situation helps, it was really annoying while looking at the one-offs layout

Attachment #9103275 - Attachment description: Bug 1586778 - Urlbar view background is transparent when ui.popup.disable_autohide is enabled. r=harry → Bug 1586778 - Urlbar view background is transparent when ui.popup.disable_autohide is enabled. r=dao
Attachment #9103275 - Attachment description: Bug 1586778 - Urlbar view background is transparent when ui.popup.disable_autohide is enabled. r=dao → Bug 1586778 - Never end address bar layout extension if the view is open. r=dao
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/edd1fb860f3c
Never end address bar layout extension if the view is open. r=dao
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
Blocks: 1589826
No longer depends on: 1589826
You need to log in before you can comment on or make changes to this bug.