Closed Bug 1586944 Opened 5 months ago Closed 3 months ago

Intermittent /html/cross-origin-embedder-policy/none.https.html | "require-corp" top-level noopener popup: navigating to "none" should succeed - assert_true: expected true got false

Categories

(Core :: DOM: Core & HTML, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- fixed
firefox72 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: juhsu)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: ccoroiu [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=270114078&repo=mozilla-inbound
Full log: https://queue.taskcluster.net/v1/task/Vfcn3qZUTZC-LqPiq7fbJA/runs/0/artifacts/public/logs/live_backing.log


[task 2019-10-07T19:30:57.660Z] 19:30:57 INFO - TEST-PASS | /html/cross-origin-embedder-policy/none.https.html | "none" top-level: navigating a frame back from "require-corp" should succeed
[task 2019-10-07T19:30:57.660Z] 19:30:57 INFO - TEST-UNEXPECTED-FAIL | /html/cross-origin-embedder-policy/none.https.html | "require-corp" top-level noopener popup: navigating to "none" should succeed - assert_true: expected true got false
[task 2019-10-07T19:30:57.660Z] 19:30:57 INFO - @https://web-platform.test:8443/html/cross-origin-embedder-policy/none.https.html:75:16
[task 2019-10-07T19:30:57.660Z] 19:30:57 INFO - Test.prototype.step_timeout/<@https://web-platform.test:8443/resources/testharness.js:1966:22
[task 2019-10-07T19:30:57.660Z] 19:30:57 INFO - Test.prototype.step@https://web-platform.test:8443/resources/testharness.js:1908:25
[task 2019-10-07T19:30:57.660Z] 19:30:57 INFO - Test.prototype.step_func/<@https://web-platform.test:8443/resources/testharness.js:1932:35
[task 2019-10-07T19:30:57.660Z] 19:30:57 INFO - setTimeout handler*Test.prototype.step_timeout@https://web-platform.test:8443/resources/testharness.js:1965:16
[task 2019-10-07T19:30:57.660Z] 19:30:57 INFO - @https://web-platform.test:8443/html/cross-origin-embedder-policy/none.https.html:73:5
[task 2019-10-07T19:30:57.660Z] 19:30:57 INFO - Test.prototype.step@https://web-platform.test:8443/resources/testharness.js:1908:25
[task 2019-10-07T19:30:57.660Z] 19:30:57 INFO - async_test@https://web-platform.test:8443/resources/testharness.js:576:22
[task 2019-10-07T19:30:57.660Z] 19:30:57 INFO - @https://web-platform.test:8443/html/cross-origin-embedder-policy/none.https.html:53:11

Note that the wpt upstream sync depends on Bug 1576153

Pushed by juhsu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/09df60fc6e23
more reliable way to detect pageLoaded, r=annevk
Failed to create upstream wpt PR due to merge conflicts. This requires fixup from a wpt sync admin.
Flags: needinfo?(wptsync)
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/20608 for changes under testing/web-platform/tests
Flags: needinfo?(wptsync) → needinfo?(juhsu)

Looks like infra timeout instead of merge/testing failure

Receiving objects:  96% (299467/310612), 127.39 MiB | 41.00 KiB/s
Receiving objects:  96% (299930/310612), 127.48 MiB | 47.00 KiB/s
Receiving objects:  96% (300035/310612), 127.53 MiB | 51.00 KiB/s
Receiving objects:  96% (300388/310612), 127.55 MiB | 46.00 KiB/s
Receiving objects:  96% (300774/310612), 127.61 MiB | 48.00 KiB/s
Receiving objects:  96% (300890/310612), 127.66 MiB | 51.00 KiB/s
##[error]The operation was canceled.
##[error]The operation was canceled.
Flags: needinfo?(juhsu)
Upstream PR merged by jgraham
You need to log in before you can comment on or make changes to this bug.