Keyboard shortcut to bring up snip context menu

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
enhancement
RESOLVED WORKSFORME
16 years ago
12 years ago

People

(Reporter: Stephan Slabihoud, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

Trunk
x86
Windows 98
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: (see comment 11))

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
It would be a "nice to have" feature:

A window that allows to select often used text phrases. I added a picture that
shows the feature in an older message reader: the user selects the entry he
wants to insert into his text.

The file that has been used was plain text with this syntax:

<text displayed for selection>|<Text thatis inserted when entry is selected>
and
<text displayed for selection>,path to file that is inserted when entry is selected

Common fields like "From:", "To:", "Subject:" and so on could be used with
placeholders, e.g.:

From: Stephan Slabihoud  (%f %F = %o)
 %f = Stephan
 %F = Slabihoud
 %o = Stephan Slabihoud
To: John Archer  (%t %T = %o)
 %t = John
 %T = Archer
 %O = John Archer

 %d = Date
 %D = Time
 %n = Newsgroup
 %s = Subject
 %% = %

So it would be more convenient to post standard answers :-)

And... (if it is not to much work :-)) The most important text phrases would be
nice to have on a shortcut key (perhaps the function keys).


These placeholders could be used to make the "reply line" more configurable, too.
See second attachment.
(Reporter)

Comment 1

16 years ago
Created attachment 92271 [details]
the window with text phrases
(Reporter)

Comment 2

16 years ago
Created attachment 92272 [details]
another way to define a "reply line"

Comment 3

16 years ago
Dupe.

(If anyone implements bug 13818 it'll need some kind of UI like you suggested)

Please reopen if I'm misunderstood your rfe..

*** This bug has been marked as a duplicate of 13818 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
Reopening on reporters request.

Stephan: please describe your RFE better (and leave out the part which is
covered by bug 13818.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: shortcut window for text phrases / improvement of reply line → shortcut window for text phrases
(Reporter)

Comment 5

16 years ago
Well, the suggestion to improve the reply line is only a small part of my rfe.

The main idea is to have predefined text blocks that can be inserted in a message:

(1) simple text blocks defined in a textfile and 
(2) a complete (longer text) defined in seperate textfiles.

Mozilla should show following list (you see it in attachment #1 [details] [diff] [review])

----------------
welcome       (1)
the dog       (2)
faq of d.c.m. (3)
...and so on
----------------

When the user selects e.g. (2) a simple text phrase like "the lazy dog jumps
oder the crazy dog" is inserted. When he selects (3) the complete content of a
textfile is inserted, when he selects (1) an welcome message is inserted (it
would be nice when placeholder are possible - even in the textfile - so text
like "Hi %f,<cr><cr>you have contacted me about "%s",... can be used).

The user should be able to define for the (e.g. 10) most important text blocks a
shortcut key. So you press F2 and the complete FAQ of a newsgroup is inserted.
Or F3 and you will get a very long welcome message ("Hello Mr.%F, thank you for
your interest in our product.").

In attachment #2 [details] [diff] [review] you can see my suggestion for placeholders that could be used
with text blocks from this rfe (and why they should not be used for the reply
line too?).

I do not think that it would be many work to implement (most work seems to be
the GUI for it) and it would be a very nice to have feature :-) Think of all the
text you have to copy and paste in News messages.

Comment 6

16 years ago
Stephan:
this could be done if http://bugzilla.mozilla.org/show_bug.cgi?id=147854 is
fixed, although insted of a window it just ask for shortcuts.
Do you agree that this is a dup?
(Reporter)

Comment 7

16 years ago
@Alfonso:

Yes and no :-)
Bug 147854 covers a small part of this enhancement only.

This bug covers shortcuts for configurable text phrases _and_ configurable
"reply lines". IMHO 158709 should not be marked as dup.

Updated

16 years ago
Summary: shortcut window for text phrases → shortcut window (clipbook) for text phrases (snips)

Comment 8

16 years ago
bug 47267 partially covers this

I think bug 147854 may be implemented. This bug, on the other hand,
should not. Reason: too advanced. But please feel free to convince me
by citing examples of applications that have extensive text insertion
feature which is actually usable.
Depends on: 47267
(Reporter)

Comment 9

16 years ago
Well, this feature is implemented in LED (the only FidoNet Message Reader for
Atari-ST systems).

You are right: This is an advanced feature but too advanced? In LED are
implemented some more "advanced" features that I miss in Mozilla Mail and News.
And... LED has been developed about thirteen years ago.

You can check some screenshots of LED here:
http://www.slabihoud.de/led/ledinfo.htm#LED
and if you want to check the sources:
http://www.slabihoud.de/led/

You see, that feature is implemented in at least one Message Reader :-)

It is very useful when you have to post standard answers (see my comment #5).
Text insertion is not difficult to implement (it is already done). Now there
must be a GUI element and a text search and replace function for the placeholders.

Comment 10

16 years ago
I didn't look at the screenshots you posted. Now having looked at
it I can understand better (your orig. description make it sound
more difficult than it does).

Your shortcuts are not the conventional keyboard shortcuts. Rather,
they are more like keywords or alias. So you want ability to assign
alias to each snip text and want Mozilla to auto expand the alias
to the full snip text, right?

This sounds reasonably easy (err... difficult?) enough.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: shortcut window (clipbook) for text phrases (snips) → Snip alias
Whiteboard: (see comment 10)
(Reporter)

Comment 11

16 years ago
> Your shortcuts are not the conventional keyboard shortcuts. Rather,
> they are more like keywords or alias. So you want ability to assign
> alias to each snip text and want Mozilla to auto expand the alias
> to the full snip text, right?

That would be a nice to have feature too but my suggestion is much more easier
to implement. I try to explain the feature step by step (I wish my native
language would be english :-)):

1. user presses a keybord shortcut (e.g. F2)
2. Mozilla displays a list with available text phrases/files
 - a text phrase is a simple text block the user can define in the GUI and that
is pasted into the email
 - a text file that would be inserted into the email

Example: display all available text phrases/files:

+-----------------------------------+
| text phrase no.1                  |
| text phrase no.2                  |
| text phrase no.3 (~\textfile.txt) |
| ...                               |
+-----------------------------------+
[Add new textphrase] [Add new file] [Remove] [Insert into EMail]
  ^                      ^
  |                     "text phrase no.3"
  +-- "text phrase no.1 and 2"

3. the user selects "text phrase no.1" and it is inserted into the email
or
   the user selects entry no.3 which points to a textfile that is inserted into
the email

4. while inserting the text Mozilla replaces placeholders (see original bug
description), e.g. "Hi %f\nThank you for your registration." is expanded to "Hi
Stephan\nThank you for your registration."


Your idea to use an alias that can be expanded with a simple text phrase or a
complete text file would be a nice feature, too. The user writes an alias and
presses e.g. F2 and Mozilla replaces this alias with a text phrase or a complete
textfile.

It does't matter if Mozilla uses a GUI element that displays all available text
phrases/files (and the user must select the phrase he wants to insert) or uses
alias that are expanded during writing. I like both ideas :-)

Updated

16 years ago
Depends on: 171744

Updated

16 years ago
No longer depends on: 47267

Comment 12

16 years ago
alright, snip alias is not the subject of this bug (could be a separate
bug). Currently in Windows the keyboard shortcut for context menu is
SHIFT+F10. What's the equivelent in Mac? And is there any standard
keyboard shortcut for `special' contxt menu?
Summary: Snip alias → Keyboard shortcut to bring up snip context menu
Whiteboard: (see comment 10) → (see comment 11)
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail

Updated

13 years ago
Blocks: 323166
(Reporter)

Comment 13

12 years ago
When you wait long enough you will get what you need ;-)

http://extensions.hesslow.se/quicktext/

"What is Quicktext:
Quicktext is an extension to Mozilla Thunderbird. It adds a menu under the subject from which you easily can insert standard texts that you have defined. You can use it for signatures or templates and it both support HTML and Plain text. You can also have shortcuts for up to ten of your texts. Another great thing is variables that you can use. For example if you have [[TO=firstname]] in a text that is added, Quicktext automatical replaces that with the firstname of the person who you are mailing to."

This is exactly hat I have asked for. Many thanks to the author!

I close the bug because of the extension.
Status: NEW → RESOLVED
Last Resolved: 16 years ago12 years ago
Resolution: --- → FIXED

Comment 14

12 years ago
No code was checked in - solved by an extension (per the OP).

-> WORKSFORME
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

12 years ago
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.