[Dogfood] Sent mail not stored anywhere that I can find

VERIFIED WORKSFORME

Status

defect
P2
normal
VERIFIED WORKSFORME
20 years ago
15 years ago

People

(Reporter: chriss, Assigned: jefft)

Tracking

Trunk
x86
Windows 95
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

I'm running Windows 95 with the 1999100812 build.
Mail server is tintin using IMAP.

Steps:
1. Compose and send email
2. Check IMAP sent folder or local sent folder
3. Message not there

Also, I can't find the pref for copying sent mail.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Chris, the preferences are stored per-account in the Edit | Account Setup dialog
box. The general FCC feature is covered by 11697, so I think this bug is a dup.


*** This bug has been marked as a duplicate of 11697 ***
Depends on: 15685
I think this is actually a result of bug 15685, since Copying to our designated
Sent folder was working before even thought the FCC decision in bug 11697
has not been reached.  In builds before 10/6 we were able to designate a Sent
folder thru the Account Setup by selecting the appropriate server, then
selecting Copies and Folders to bring up the panel for making that designation.
Currently we can't do that using Account Setup so Copies go nowhere.  This can't
be verified until 15685 is fixed, so marking this bug dependent on 15685.
Status: RESOLVED → REOPENED
Assignee: phil → rhp
Status: REOPENED → NEW
Priority: P3 → P2
Ok, then reassign to rhp, cc alecf
If you need a workaround before the bug is fixed, you can edit your prefs.js
file to fill in the location for the account where you want Sent folder:
Find the line user_pref("mail.identity.id1.fcc_folder", "...");
and replace the "..." with your location as the example below shows:
user_pref("mail.identity.id1.fcc_folder", "mailbox://qatest04@nsmail-2/Sent");
Note: the Account Setup UI for Copies and Folders will still show the wrong
location but your copies will be sent to the location you entered in your
prefs.js.
Resolution: DUPLICATE → ---
clear resolution.
Status: NEW → ASSIGNED
Yeah, esther is absolutely right. This should work once I get those widgets
fixed in the account manager.
Whiteboard: [PDT+]
Putting on [PDT+] radar.
Assignee: rhp → jefft
Status: ASSIGNED → NEW
Hi Jeff,
Can you help me out on this one. I was just going through this bug to make sure
that copying was still working and what I noticed was that I had to quit the
application and restart for my messages to actually appear in the "Sent"
folder.

This may not be your bug, but you probably know who this belongs to at this
point in the project. I call the copy service to copy a file from disk to the
"Sent" mail folder and I know the data is getting there, but the threadpane
doesn't seem to refresh until a restart.

Just let me know if you have any questions and thanks for the help.

- rhp
Status: NEW → ASSIGNED
Target Milestone: M11
Sure. No problem.
I was setting my Sent copy to local mail folder and found out that the reason we
failed is because we failed to set the Fcc to the composition fields. The dos
prompt also print out that "the fcc is disabled by the user" for some reason.
I'll look into more.
Assignee: jefft → alecf
Status: ASSIGNED → NEW
I think alecf should own this bug until he finished all his work. Until then, if
things still not working reassign back to me.
Status: NEW → ASSIGNED
yeah, no problem.
Assignee: alecf → jefft
Status: ASSIGNED → NEW
ok, the select widget works again. Reassigning back to jefft
Status: NEW → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → WORKSFORME
This working for me now, Imap or Pop3, as long as you have the fcc folder set up
correctly with your identity. For example, using identity - qatest21, imap
server - nsmail-2. Then you need to have the following prefs correctly set (in
general this should be handle by the Account Setup pref):

user_pref("mail.identity.qatest21.fcc", true);
user_pref("mail.identity.qatest21.fcc_folder", "imap://qatest21@nsmail-2/Sent");
QA Contact: lchiang → esther
Status: RESOLVED → VERIFIED
Using build 1999111017 on win98 and linux and 1999111011 mac mozilla build,
after setting the Sent folder designation in the Account setup and checking the
box, a copy goes to the correct designated folder per account from which the
message was sent.  i.e. Selection is on qatest04 POP account, for that account,
I have designated a copy to go to the "Sent" folder in that account and it does.
 Selection is on 3qatest07 IMAP account, for this account I have designated a
copy to go to the "Misc" folder in that account and it does.   The original bug
reported is fixed, however I did have some difficulty the first time I sent to
the POP folders, but once one message was sent there it was no problem.  I will
verify this one and investigate the other issue so I can log a more specific
bug.  Verified
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.