Open Bug 1587685 Opened 2 months ago Updated 18 days ago

Some source page features disappear when directly open the "view-source:URL" from urlbar or bookmark.

Categories

(Toolkit :: View Source, defect, P5)

60 Branch
x86
Linux
defect

Tracking

()

Tracking Status
firefox-esr68 --- affected
firefox70 --- wontfix
firefox71 --- fix-optional
firefox72 --- fix-optional

People

(Reporter: letek, Unassigned)

Details

(Keywords: regression, regressionwindow-wanted, Whiteboard: [tor 31977])

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0

Steps to reproduce:

directly open the view-source:https://check.torproject.org/ URL from urlbar or bookmark

Actual results:

Some source page features disappeared in the source page(at least include "goto line" and "source page context menu"

Expected results:

I expect get all features that documented in ​https://developer.mozilla.org/en-US/docs/Tools/View_source#View_Source_features

OS: Unspecified → Linux
Hardware: Unspecified → x86

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Address Bar
Whiteboard: [tor 31977]

The priority flag is not set for this bug.
:adw, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(adw)

60 is quite an old version. Could you please try to reproduce on the current release or Nightly? The context menu shows up for me on Nightly, and it has the Go to Line command.

Component: Address Bar → View Source
Flags: needinfo?(adw) → needinfo?(letek)
Product: Firefox → Toolkit

(In reply to Drew Willcoxon :adw from comment #3)

60 is quite an old version. Could you please try to reproduce on the current release or Nightly? The context menu shows up for me on Nightly, and it has the Go to Line command.

I just tried with 70.0.1. I can still reproduce the bug. Note, things seem to work if you start a new profile and paste the test URL (say, view-source:https://bugzilla.mozilla.org/show_bug.cgi?id=1588515) in a new tab. However, you can see the bug after shutting down the browser and restarting (not having any URL shown in the URL bar after start-up). That's on a Linux box.

Flags: needinfo?(letek)

I can reproduce this issue on the current Nightly + Win10

STR:

  1. Uncheck "Restore previous session" in Firefox Options (Tools -> Options on Win, Firefox -> Preferences on OSX)
  2. Restart the browser
  3. Put view-source:https://check.torproject.org/ URL in the address bar and press Enter key
  4. Right click on the page and check out the context menu: Go to line... & Wrap Long Lines & Syntax Highlighting items are missing -> BUG

This might be a regression

Honza

Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression

Managed to reproduce the issue one time with 72.0a1 (2019-11-07), 66.0b2; after that it was harder to reproduce.
Trying to get mozregression for the bisection was out of the question since the results where inconsistent for some reason.
While trying to get the regression range 59.0b14, 60.0.1.esr, 60.0b3 appear not having the options at all.

One thing worth mentioning is that steps 1+2 are really important:

  1. Uncheck "Restore previous session" in Firefox Options (Tools -> Options on Win, Firefox -> Preferences on OSX)
  2. the Restart afterwards.
    In some cases the restart was not needed as the issue manifested but it persisted until the above mentioned steps were re-run.

Inclined to say it's not a regression in the end, but something that came up @60; if indeed it's the version this feature was added.
Versions before didn't have the context menu options at all.
Anyone who could confirm this?

Priority: P3 → P5
You need to log in before you can comment on or make changes to this bug.