Closed Bug 1587705 Opened 5 years ago Closed 5 years ago

The “CFR Recommendation” button is not displayed in the minimized form after navigating to another website on the same tab

Categories

(Firefox :: Messaging System, defect)

Desktop
All
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- wontfix
firefox71 --- verified

People

(Reporter: srosu, Assigned: andreio)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(3 files)

Attached video CFR_Minimized.mp4

[Affected versions]:

  • Firefox Beta 70.0b13 build (Build ID: 20191007220302) (64-bit)
  • Nightly 71.0a1 build (Build ID: 20191009213914) (64-bit)

[Affected Platforms]:

  • Windows 10 x64
  • Mac 10.14
  • Ubuntu 16.04 x64.

[Prerequisites]:

  • You are not signed in to sync.

[Steps to reproduce]:

  1. Open the Firefox browser with the profile from prerequisites.
  2. Navigate to a login page of a website for which you don’t have the credentials saved (eg: https://twitter.com/login).
  3. Complete the username and password fields with valid credentials and click the “Login” button.
  4. Click the "Save" button from the "Save password" doorhanger.
  5. Navigate to another website on the same tab and observe "CRF Recommendation" button from the right part of the “Address Bar”.

[Expected result]:

  • The "CRF Recommendation" button is minimized.

[Actual result]:

  • The "CRF Recommendation" button is still displayed in the maximized form..

[Notes]:

  • Attached a screen recording with the issue.

Using mozregression I tracked this down to bug 1513337. It looks like the focus event listener is added but it never fires when clicking the awesomebar.

:ntim did something change in that bug that you might think triggers this?

Has Regression Range: --- → yes
Flags: needinfo?(ntim.bugs)
Regressed by: 1513337

Redirecting to dao who worked on bug 1513337 and knows more on the urlbar than I do :)

Flags: needinfo?(ntim.bugs) → needinfo?(dao+bmo)
Flags: needinfo?(dao+bmo)
Assignee: nobody → andrei.br92

Comment on attachment 9100238 [details]
Bug 1587705 - The CFR Recommendation button is not displayed in the minimized form on urlbar focus

Beta/Release Uplift Approval Request

  • User impact if declined: Regression in the CFR message UI
    The message does not collapse/minimize and remains in its expanded state until dismissed by the user
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is a regression that was discovered very late but the patch itself is small and there is no risk to taking it.
  • String changes made/needed:
Attachment #9100238 - Flags: approval-mozilla-beta?
Pushed by aoprea@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9daa83397ca7
The CFR Recommendation button is not displayed in the minimized form on urlbar focus r=k88hudson
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

I have verified this issue on the latest Nightly 71.0a1 (Build ID: 20191011093010) on Windows 10 x64, Mac 10.14, Ubuntu 16 x64.

  • The “CFR Recommendation” button is correctly displayed in the minimized form after navigating to another website on the same tab
Status: RESOLVED → VERIFIED

Seems fairly edge case to me, I think this can wait for 71. If you strongly disagree and think the user impact is major, you can let me know.

Attachment #9100238 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: