Inline quantumbar markup into browser.xhtml

RESOLVED FIXED in Firefox 70

Status

()

task
P1
normal
RESOLVED FIXED
7 months ago
2 days ago

People

(Reporter: ntim, Assigned: dao)

Tracking

(Blocks 5 bugs, Regressed 2 bugs)

Trunk
Firefox 70
Points:
3
Dependency tree / graph

Firefox Tracking Flags

(firefox70 fixed)

Details

Attachments

(1 attachment)

The urlbar binding is markup only, so that could be inlined in browser.xul.

This would require figuring out a way to get rid of the textbox binding dependency.
Blocks: 1513325
Component: XUL Widgets → Address Bar
Priority: -- → P3
Product: Toolkit → Firefox
Depends on: 1514497
Depends on: 1514505
Depends on: 1514509
Depends on: 1515589
Note that the binding has some useless inherits:
- inherits="pageproxystate" on urlbar-go-button
- very likely one of the inherits on urlbar-input
- parentfocused on urlbar-history-dropmarker seems unused ?

Either way, most of the inherits usage just ease up the styling and can usually be reproduced with descendant selectors in the CSS.
No longer blocks: quantumbar-input
Duplicate of this bug: 1534331

Dao, could you answer bug 1534331 comment #3?

Flags: needinfo?(dao+bmo)

We shouldn't use a custom element here, so the question doesn't really apply.

Flags: needinfo?(dao+bmo)

(In reply to Dão Gottwald [::dao] from comment #4)

We shouldn't use a custom element here, so the question doesn't really apply.

k

(In reply to Tim Nguyen :ntim from comment #0)

The urlbar binding is markup only, so that could be inlined in browser.xul.

This would require figuring out a way to get rid of the textbox binding
dependency.

so the idea is to pour urlbar content right into <textbox> children?

The idea is to not use a textbox at all.

(In reply to Dão Gottwald [::dao] from comment #6)

The idea is to not use a textbox at all.

Are any of these properties are needed for urlbar implementation? https://searchfox.org/mozilla-central/source/toolkit/content/widgets/textbox.xml#50

So the idea is to replace textbox on ordinal container like hbox and then style it properly? How would it live together with no quantumbar implementation?

(In reply to alexander :surkov (:asurkov) from comment #7)

(In reply to Dão Gottwald [::dao] from comment #6)

The idea is to not use a textbox at all.

Are any of these properties are needed for urlbar implementation? https://searchfox.org/mozilla-central/source/toolkit/content/widgets/textbox.xml#50

Maybe, but I think it'll probably be caught by tests if something breaks.

So the idea is to replace textbox on ordinal container like hbox and then style it properly? How would it live together with no quantumbar implementation?

Since the markup is the same for both quantumbar and non-quantumbar, I guess the markup for both urlbar bindings can be inlined, with the legacy-urlbar binding kept to attach different behaviours to the element.

I think this bug would be easier to fix with bug 1515589 fixed first.

I won't have time to finish this, but here's a possible plan if you'd like to work on this:

  • Fix bug 1515589
  • Remove or port the inherits="" attributes
  • Fix the "X is undefined" errors
  • Potentially more stuff

Hi Dão,

Do you have some cycles to take this over the finish line? The current patch mostly works for both the old and new URL bar, but has some bugs there and there.

Some notable issues are: the go button doesn’t appear, live switching implementations doesn’t work super well.

I think it might be faster if you or someone from your team finishes this, given that you’re more familiar with this code.

Thanks.

Flags: needinfo?(dao+bmo)

We shouldn't spend time on this until after quantumbar is released and the old urlbar is removed.

Depends on: quantumbar
Flags: needinfo?(dao+bmo)

(In reply to Dão Gottwald [::dao] from comment #13)

We shouldn't spend time on this until after quantumbar is released and the old urlbar is removed.

Do you mean that you/your team doesn't have cycles to finish this before quantumbar released or this work may interfere with some other planned work and thus it's better to delay it until it done? It'd be just cool to have it resolved asap for deXBLization project.

Flags: needinfo?(dao+bmo)

It may interfere and imply noise we don't need right now, but that aside what I'm saying is it makes much more sense to do this when we don't have to worry about the old urlbar anymore, which will be soon enough. The old urlbar is all XBL so that's a blocker for deXBL anyway.

Flags: needinfo?(dao+bmo)

for the record, this bug can help fix bug 1534661, which doesn't work because aria-owns inside urlbar binding refers outside the binding, because it's not allowed. This bug suggests to pour the urlbar content into a document, what will fixe aria-owns issue.

See Also: → 1534661
Depends on: quantumbar-release
No longer depends on: quantumbar
Type: enhancement → task
Depends on: 1551834
Depends on: 1554864
Blocks: 1561531
Points: --- → 3
Priority: P3 → P2
Blocks: 1551598
Depends on: 1551232
Summary: Inline quantumbar markup into browser.xul → Inline quantumbar markup into browser.xhtml
Attachment #9050407 - Attachment description: Bug 1513337 - Inline urlbar markup into browser.xul. → Bug 1513337 - Inline urlbar markup into browser.xhtml.
Blocks: 1561533
No longer blocks: 1561531

ntim, this will become a priority next week once bug 1551232 has landed. Do you intend to finish this (I see you already updated the patch a few days ago) or should somebody else take this over?

Iteration: --- → 70.1 - Jul 8 - 21
OS: Unspecified → All
Priority: P2 → P1
Hardware: Unspecified → All
Version: unspecified → Trunk
Flags: needinfo?(ntim.bugs)

(In reply to Dão Gottwald [::dao] from comment #17)

ntim, this will become a priority next week once bug 1551232 has landed. Do you intend to finish this (I see you already updated the patch a few days ago) or should somebody else take this over?

I don't plan on finishing this anytime soon. Feel free to take this over.

Flags: needinfo?(ntim.bugs)
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a7c14ebfcd4d
Inline urlbar markup into browser.xhtml. r=mak
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cf34b2e8ac53
Inline urlbar markup into browser.xhtml. r=mak
Flags: needinfo?(dao+bmo)
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3504c0b3f87c
Inline urlbar markup into browser.xhtml. r=mak
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a0c57ddf0725
Inline urlbar markup into browser.xhtml. r=mak
Flags: needinfo?(dao+bmo)
Status: ASSIGNED → RESOLVED
Closed: 3 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Regressions: 1567141
Regressions: 1567377
Regressions: 1567384
Blocks: 1566324
Blocks: 1567406
Blocks: 1567426
You need to log in before you can comment on or make changes to this bug.