Closed Bug 1588079 Opened 1 year ago Closed 1 year ago

Protection panels are not displayed on RTL builds

Categories

(Firefox :: Messaging System, defect)

71 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1588199
Tracking Status
firefox71 --- affected

People

(Reporter: simona.marcu, Unassigned)

References

(Blocks 1 open bug)

Details

Mozilla/5.0 (X11; Linux x86_64; rv:71.0) Gecko/20100101 Firefox/71.0
Build ID: 20191010214019

Affected platforms

  • Windows 10 x64
  • Ubuntu 18.04 x64
  • Mac OS X 10.14

Pre-requisites:

  • Install an "ar" build
  • In about:config change the pref "browser.newtabpage.activity-stream.asrouter.devtoolsEnabled" to true

Steps to reproduce:

  1. Launch Firefox
  2. Open about:newtab#devtools search for CRYPTOMINERS_PROTECTION
  3. Click on the "Show" button
  4. Look for the SOCIAL_TRACKING_PROTECTION section and click on the "Show" button
  5. Look for the FINGERPRINTERS_PROTECTION section and click on the "Show" button

Expected results:
3. The cryptominer panel is correctly displayed.
4. The Social Tracking Protection panel is correctly displayed.
5. The fingerprinters panel is correctly displayed.

Actual results:
3, 4, 5 None of the privacy protection panels is displayed. I partially reproduced this issue also on a "he" build - the cryptominer panel is not displayed (the other 2 are displayed).

Blocks: 1573445

Kate, Gary, can you take a look at this? Is it not showing because of missing translations?

Flags: needinfo?(xeonchen)
Flags: needinfo?(khudson)

It's possible, I'm re-triaging this into our component to verify/debug

Component: Protections UI → Messaging System
Flags: needinfo?(khudson)

I'm unable to reproduce this on ar or he builds (all three are showing up fine via devtools).

I wondered if maybe it was because strings were missing and are now available, but I tested a Bengali build (which still has English strings) and I was still unable to reproduce – can you still see this issue?

Pretty sure this is bug 1588199. I do see that remote strings for "ar" did not have at least cfr-doorhanger-socialtracking-heading so it would prevent showing of that panel.

Simona, can you check if things are fixed in nightly 71.0a1 20191016095255 or newer?

Blocks: 1564187
Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(xeonchen) → needinfo?(simona.marcu)
Resolution: --- → DUPLICATE
Duplicate of bug: 1588199

(In reply to Ed Lee :Mardak from comment #4)

Pretty sure this is bug 1588199. I do see that remote strings for "ar" did not have at least cfr-doorhanger-socialtracking-heading so it would prevent showing of that panel.

Simona, can you check if things are fixed in nightly 71.0a1 20191016095255 or newer?

Things look good in the latest Nightly 71.0a1 - 20191020214712. I can no longer reproduce the initial issue.

Flags: needinfo?(simona.marcu)
You need to log in before you can comment on or make changes to this bug.