Closed Bug 1588197 Opened 1 year ago Closed 9 months ago

Add autoplay to our permissions policies

Categories

(Firefox :: Enterprise Policies, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 74
Tracking Status
firefox-esr68 --- fixed
firefox74 --- fixed

People

(Reporter: mkaply, Assigned: southort)

References

Details

(Keywords: good-first-bug)

Attachments

(1 file, 1 obsolete file)

We should add autoplay to our permissions policies:

Services.perms.add(NetUtil.newURI("https://www.youtube.com"), "autoplay-media", 1);

Keywords: good-first-bug

Hi there,

I am an UofT CS student doing bug-hunting for a course. Here is the link to my report for this bug https://github.com/JaydeYue/gecko-dev/blob/master/docs/A3.md, lmk if there is anything else I need to do. I will try to test it next weekend or whenever I have time.

Cheers,
Jayde

This should only require a chance to policies-schema.json and Policies.jsm.

Looking at

https://bugzilla.mozilla.org/show_bug.cgi?id=1467062

should provide some guidance.

Also, we don't use Github for patches to the tree.

See

https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Introduction

Thank you for working on this, by the way!

Alright, feel free to assign this to me, I will see this through.

Assignee: nobody → yue.jayde

Jayde: Are you planning to finish this bug?

Thanks

Flags: needinfo?(yue.jayde)

Hi Mike, I've added added autoplay to both the policies.jsm and policies-schema.json, will it also be included in the browser_policy_permissions.js?

Reassigning due to lack of info from original contributor.

Assignee: yue.jayde → southort
Flags: needinfo?(yue.jayde)

Are you going to do this last change?

Flags: needinfo?(southort)
Attachment #9113261 - Attachment is obsolete: true
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/572a42a3fffb
Add autoplay to our permissions policies. r=mkaply,fluent-reviewers,Gijs,flod
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 74

Comment on attachment 9113365 [details]
Bug 1588197 - Add autoplay to our permissions policies. r=mkaply

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: Policy updates
  • User impact if declined: Unable to set autoplay via policy.
  • Fix Landed on Version: 74
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Policy only, has automated test.
  • String or UUID changes made by this patch: Adds new string to change text. Policy strings are approved for English only for ESR.
Attachment #9113365 - Flags: approval-mozilla-esr68?

Comment on attachment 9113365 [details]
Bug 1588197 - Add autoplay to our permissions policies. r=mkaply

Policy engine update needed for Fx74 parity. Approved for 68.6esr.

Attachment #9113365 - Flags: approval-mozilla-esr68? → approval-mozilla-esr68+
Duplicate of this bug: 1617309
Flags: needinfo?(southort)
You need to log in before you can comment on or make changes to this bug.