Closed Bug 1588218 Opened 1 year ago Closed 1 year ago

Expose DNS suffix list (Android)

Categories

(Core :: Networking: DNS, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox72 --- fixed

People

(Reporter: valentin, Assigned: valentin)

References

(Depends on 4 open bugs, Blocks 1 open bug)

Details

(Whiteboard: [necko-triaged])

Attachments

(1 file)

No description provided.
Priority: P2 → P1

Hi James,

I found this Android API https://developer.android.com/reference/android/net/LinkProperties.html#getDomains() that seems to give me exactly what I need. I was considering calling it from GeckoAppShell.java like we do for ex. isNetworkLinkUp
The problem is that LinkProperties is API level 21+ but the wiki says GeckoView requires Android OS version 4.3 (API Level 18) or later. For comparison, Fennec supports Android 4.1 (API level 16) and later. Fenix and Focus support Android 5.0 (API level 21) and later.. Do we need to worry about pre API level21 platforms?

Flags: needinfo?(snorp)

We do need to care about API < 21 for now. In this case, simply returning an empty list will probably suffice in that situation.

Flags: needinfo?(snorp)
Attachment #9106103 - Attachment description: Bug 1588218 - Expose DNS suffix list (Android) → Bug 1588218 - Expose DNS suffix list (Android) r=michal!,snorp!
Blocks: 1595611
Pushed by valentin.gosu@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/6384318223b4
Expose DNS suffix list (Android) r=michal,snorp
Flags: needinfo?(valentin.gosu)
Flags: needinfo?(valentin.gosu)
Pushed by valentin.gosu@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/2d2a7cb4d6ff
Expose DNS suffix list (Android) r=michal,snorp
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
Blocks: 1600250
No longer blocks: 1600250
Depends on: 1600250
Depends on: 1600616
Depends on: 1600938
Depends on: 1613629
You need to log in before you can comment on or make changes to this bug.