Closed Bug 1588434 Opened 2 months ago Closed 2 months ago

Picture-in-Picture: titlebar=no cause resizing not working on macOS

Categories

(Toolkit :: Video/Audio Controls, defect, P3)

71 Branch
Unspecified
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1567009
Tracking Status
firefox71 --- affected

People

(Reporter: ren.chiang, Unassigned)

References

(Blocks 1 open bug)

Details

Under macOS, the current picture-in-picture implementation would result in a floating window without rounded borders and unable to resize. The problem persists in both stable (69.0.3) and Nightly (71.0a1 2019-10-14, built from source).

Upon further inspection, removing titlebar=no in PictureInPicture.jsm would fix the issue. Window feature lockaspectratio and alwaysontop are not working, so I’ll need to take additional time to get that to work.

Is it appropriate for me to send a patch for this single issue? Any suggestions would be appreciated!

Hi Poren,

We haven't yet started on adding the widgetry support for macOS, but that should start in a few weeks. We'll be filing bugs for the alwaysontop and lockaspectratio support as well.

Blocks: 1532675
Priority: -- → P3
Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1567009
You need to log in before you can comment on or make changes to this bug.