Closed Bug 1567009 Opened 1 year ago Closed 1 year ago

User should be able to resize video when in picture in picture mode

Categories

(Toolkit :: Video/Audio Controls, defect, P3)

69 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla72
Tracking Status
firefox72 --- verified

People

(Reporter: bharath.sivakumar98, Assigned: mconley)

References

(Regressed 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

  • Launch firefox
  • Opened video on youtube
  • entered PiP mode
  • Attempted to resize video while in PiP by selecting a corner and dragging

Actual results:

Unable to resize PiP window

Expected results:

PiP window should have resized to the user's preference

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Hi,

You have that issue because the PiP feature is not implemented for Mac OS yet. On Windows, where the feature is implemented, the preferences are set by default, PiP window can be resized correctly.

Thanks for the report.

Component: Untriaged → Video/Audio Controls
Product: Firefox → Toolkit

ni mconley for PiP triage

Flags: needinfo?(mconley)
Blocks: 1532675
Flags: needinfo?(mconley)
Priority: -- → P3
Duplicate of this bug: 1588434

With titlebar=no, we were falling into this branch:
https://searchfox.org/mozilla-central/rev/8a63fc190b39ed6951abb4aef4a56487a43962bc/widget/cocoa/nsCocoaWindow.mm#344

and the NSBorderlessWindowMask doesn't allow for resizing. I don't actually think
we need titlebar=no, because with the chromemargin attribute set at
https://searchfox.org/mozilla-central/rev/8a63fc190b39ed6951abb4aef4a56487a43962bc/toolkit/components/pictureinpicture/content/player.xhtml#12

we end up drawing into the titlebar anyways.

So setting titlebar=yes means that we get a resizable window, and it doesn't appear
to effect the window visually.

Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5dc0fcde3bec
Remove titlebar=no rule for the Picture-in-Picture player window to allow resizing on macOS. r=mstriemer
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72

Verified - fixed on latest Nightly 72.0a1 (2019-10-23)(Build id: 20191023215406) on Mac OS 10.14.

Status: RESOLVED → VERIFIED
Regressions: 1617123
You need to log in before you can comment on or make changes to this bug.