sub-windows (e.g., completion pop-down, context menus, tooltips, others?) can appear on wrong monitor in multiple monitor setup

RESOLVED DUPLICATE of bug 98830

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 98830
16 years ago
14 years ago

People

(Reporter: Scott Collins, Assigned: jag (Peter Annema))

Tracking

(Blocks: 1 bug)

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1b) Gecko/20020722
BuildID:    2002072203

If the URL bar of the active window is on a secondary monitor, typing into it
will cause the pop-down completion menu to appear (at the top left corner) on
the main monitor, very far away from where one is actually typing.

My system is a PowerBook DVI driving a second LCD in non-mirror mode.  I
experience this problem with 100% reproducibility whenever working with windows
on the second screen.

Reproducible: Always
Steps to Reproduce:
1. have more than one monitor
2. drag a browser window to a secondary monitor
3. start typing in the URL bar

Actual Results:  completion menu appears on the primary monitor, very far away

Expected Results:  completion menu should appear on as though it is attached to
(i.e., dropped down from) the URL entry field
(Reporter)

Comment 1

16 years ago
...in fact, context menus (e.g., right-click on a URL) pop up on the wrong
monitor as well.  How annoying.
(Reporter)

Comment 2

16 years ago
any relation to bug #33438?
(Reporter)

Comment 3

16 years ago
tooltips also appear on the wrong monitor, changing summary to better reflect
the larger problem
Summary: url completion menu appears on wrong monitor in multiple monitor setup → sub-windows (e.g., completion pop-down, context menus, tooltips, others?) can appear on wrong monitor in multiple monitor setup

Comment 4

16 years ago
This appears very similar to bug 141204. Reporter, can you confirm whether your
problems go away if you restart Mozilla after detecting the second monitor? If
so we should just confirm bug 141204 (after another dupe search) and mark this
one as a dupe of it. If not then there may be a couple of underlying problems.
(Meanwhile I just wish I had a PowerBook and a second screen with which to
investigate the problem :-)

Comment 5

16 years ago
Seems related to bug #98830

Comment 6

15 years ago
*** Bug 141204 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
This also occurs under Windows XP with multiple displays attached through that
OS's "Extend my Windows desktop onto this monitor" feature.  Context menus and
URL completion windows for a browser window in the extended desktop area appear
right-aligned on the primary display.  With the same setup, a browser window
contained within the primary desktop area does not experience any problems. 
Also, a browser window spanning the desktop areas will only experience the
problem when the context menu is fired from the secondary display area.

Comment 8

15 years ago
I'd like to add that this happens intermittantly on my powerbook. It is not
restricted to right-clicks (or "control clicks" as I'm on OS X), it affects all
pop-ups, including left-click on tab-groups, and just typing into the url bar
(history popup) or form inputs.

I have *not* been able to pin down the series of events that trigger it, and I
have tried very complex series of removing 2nd monitor before & after sleep,
with no windows open, with window only on primary or only on 2ndary monitor,
etc. I am fairly certain that the problem is triggered while there are *no*
windows open, and affects the next solo window that gets created. But not
always, and I still can't figure out what other conditions are necessary for it
to start happening.

While this doesn't help much, I can offer that I would be happy to drive a
specially instrumented browser for a while that looks for this and can capture
data for you guys when it happens - I wouldn't mind if it was slower as a result. 

Comment 9

15 years ago
It looks like this is a dup of bug 138905.  Anyone care
to look at both and second the motion?

Still seeing this with very current Mozilla and Mac OS X
(1.6 and 10.3.2, respectively).

Updated

14 years ago
Blocks: 236647

Comment 10

14 years ago
This also appears to apply to the main menus ie File, Edit, View. When I click
these, the drop down menu always appears on the primary monitor.

Comment 11

14 years ago
This also occurs with the main file, edit, view menu bar items - selecting any
of these causes the drop down to appear on primary display

Comment 12

14 years ago
It appears to me that the problem is if your secondary monitor is to the left 
of the primary display, such that your Mozilla is running within a negative 
coordinate space. Seems to be using unsigned values somewhere where signed 
would be more appropriate

Comment 13

14 years ago

*** This bug has been marked as a duplicate of 98830 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.