Closed Bug 1589189 Opened 3 months ago Closed 2 months ago

Update noreferrer code

Categories

(SeaMonkey :: General, task)

task
Not set

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 affected, seamonkey2.57esr fixed)

RESOLVED FIXED
seamonkey2.69
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- affected
seamonkey2.57esr --- fixed

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

Details

Attachments

(1 file, 1 obsolete file)

Port parts / all of the following bugs:

  • Bug 1031264 - make opening links in new {tabs,windows} honor rel="noreferrer"
  • Bug 1072980 - Don't allow CPOWs to be passed to C++ code
  • Bug 1113431 - Propagate referrer policy throughout the UI: command-click and context menu open link in new tab/window
  • Bug 1133577 - Make context-menu open link/frame commands use messages to avoid unsafe CPOW warnings
  • Bug 1118502 - part 2 - ensure addOneTab sees a referrer URI if it was available
  • Bug 1409226 - When opening a link into a new private window, remove Referer
  • Bug 1409248 - Don't send a referrer if right-click opening a selected plain-text link
  • Bug 1271516 - Introducing nsIWebNavigation.setOriginAttributesBeforeLoading
  • Bug 1277765 - No referrer when a link is opened by middle-click or the context menu and containers are involved
  • Bug 1248251 - We should not send the referrer when a link is open in a different container
  • Bug 1248302 - We should not show any decoration for tab with usercontextid=0
  • Bug 1246907 - Open link in a Container Tab - in the context menu
  • Bug 1284395 - Show about:blank (placeholder "Search or enter address" in the URL bar)
  • Bug 1344706 - Do not reuse originPrincipal as triggeringPrincipal within utilityOverlay.js
Attached patch Update code (obsolete) — Splinter Review

Tested against 2.53
Probably need a list of good sites to test these sort of fixes against

Attachment #9101654 - Flags: review?(frgrahl)
Attachment #9101654 - Flags: approval-comm-release?
Attachment #9101654 - Flags: approval-comm-esr60?
Duplicate of this bug: 1332931
Blocks: 1595424
Attached patch Update code v1.2Splinter Review

Port missed part of port of bug 1284395, have navigator.js' Startup use forceAboutBlankViewerInCurrent by switching it to use loadURI(...) like Firefox's browser.js

Attachment #9101654 - Attachment is obsolete: true
Attachment #9101654 - Flags: review?(frgrahl)
Attachment #9101654 - Flags: approval-comm-release?
Attachment #9101654 - Flags: approval-comm-esr60?
Attachment #9108065 - Flags: review?(frgrahl)
Attachment #9108065 - Flags: approval-comm-release?
Attachment #9108065 - Flags: approval-comm-esr60?
Comment on attachment 9108065 [details] [diff] [review]
Update code v1.2

LGTM
Attachment #9108065 - Flags: review?(frgrahl)
Attachment #9108065 - Flags: review+
Attachment #9108065 - Flags: approval-comm-release?
Attachment #9108065 - Flags: approval-comm-release+
Attachment #9108065 - Flags: approval-comm-esr60?
Attachment #9108065 - Flags: approval-comm-esr60+
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.