Closed Bug 1589867 Opened 2 years ago Closed 2 years ago

Perma| browser/base/content/test/static/browser_parsable_css.js | Got error message for resource://devtools/client/webconsole/components/App.css: Unknown property ‘rotate’. Declaration dropped. when Gecko 71 merges to Beta on 2019-10-14

Categories

(DevTools :: Console, defect)

71 Branch
defect
Not set
normal

Tracking

(firefox-esr60 unaffected, firefox-esr68 unaffected, firefox67 unaffected, firefox68 unaffected, firefox69 unaffected, firefox70 unaffected, firefox71 fixed, firefox72 verified)

VERIFIED FIXED
Firefox 72
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- fixed
firefox72 --- verified

People

(Reporter: aiakab, Assigned: nchevobbe)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:

Central as beta: https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=unclassified&revision=411419d4250c8a975474b4434e4f0a2488866218&selectedJob=272037378

Failure log https://treeherder.mozilla.org/logviewer.html#?job_id=272037378&repo=try

Part of that log:
[task 2019-10-19T13:48:05.946Z] 13:48:05 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-native-anonymous’. Ruleset ignored due to bad selector." on resource://devtools/server/actors/highlighters.css because of whitelist item {"sourceName":"/highlighters\.css$/i","errorMessage":"/Unknown pseudo-class.*moz-native-anonymous/i","isFromDevTools":true,"used":true}
[task 2019-10-19T13:48:05.946Z] 13:48:05 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-native-anonymous’. Ruleset ignored due to bad selector." on resource://devtools/server/actors/highlighters.css because of whitelist item {"sourceName":"/highlighters\.css$/i","errorMessage":"/Unknown pseudo-class.*moz-native-anonymous/i","isFromDevTools":true,"used":true}
[task 2019-10-19T13:48:05.947Z] 13:48:05 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-native-anonymous’. Ruleset ignored due to bad selector." on resource://devtools/server/actors/highlighters.css because of whitelist item {"sourceName":"/highlighters\.css$/i","errorMessage":"/Unknown pseudo-class.*moz-native-anonymous/i","isFromDevTools":true,"used":true}
[task 2019-10-19T13:48:05.947Z] 13:48:05 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-native-anonymous’. Ruleset ignored due to bad selector." on resource://devtools/server/actors/highlighters.css because of whitelist item {"sourceName":"/highlighters\.css$/i","errorMessage":"/Unknown pseudo-class.*moz-native-anonymous/i","isFromDevTools":true,"used":true}
[task 2019-10-19T13:48:05.948Z] 13:48:05 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-native-anonymous’. Ruleset ignored due to bad selector." on resource://devtools/server/actors/highlighters.css because of whitelist item {"sourceName":"/highlighters\.css$/i","errorMessage":"/Unknown pseudo-class.*moz-native-anonymous/i","isFromDevTools":true,"used":true}
[task 2019-10-19T13:48:05.948Z] 13:48:05 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-native-anonymous’. Ruleset ignored due to bad selector." on resource://devtools/server/actors/highlighters.css because of whitelist item {"sourceName":"/highlighters\.css$/i","errorMessage":"/Unknown pseudo-class.*moz-native-anonymous/i","isFromDevTools":true,"used":true}
[task 2019-10-19T13:48:05.948Z] 13:48:05 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-native-anonymous’. Ruleset ignored due to bad selector." on resource://devtools/server/actors/highlighters.css because of whitelist item {"sourceName":"/highlighters\.css$/i","errorMessage":"/Unknown pseudo-class.*moz-native-anonymous/i","isFromDevTools":true,"used":true}
[task 2019-10-19T13:48:05.949Z] 13:48:05 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-native-anonymous’. Ruleset ignored due to bad selector." on resource://devtools/server/actors/highlighters.css because of whitelist item {"sourceName":"/highlighters\.css$/i","errorMessage":"/Unknown pseudo-class.*moz-native-anonymous/i","isFromDevTools":true,"used":true}
[task 2019-10-19T13:48:05.950Z] 13:48:05 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-native-anonymous’. Ruleset ignored due to bad selector." on resource://devtools/server/actors/highlighters.css because of whitelist item {"sourceName":"/highlighters\.css$/i","errorMessage":"/Unknown pseudo-class.*moz-native-anonymous/i","isFromDevTools":true,"used":true}
[task 2019-10-19T13:48:05.950Z] 13:48:05 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-native-anonymous’. Ruleset ignored due to bad selector." on resource://devtools/server/actors/highlighters.css because of whitelist item {"sourceName":"/highlighters\.css$/i","errorMessage":"/Unknown pseudo-class.*moz-native-anonymous/i","isFromDevTools":true,"used":true}
[task 2019-10-19T13:48:05.950Z] 13:48:05 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-native-anonymous’. Ruleset ignored due to bad selector." on resource://devtools/server/actors/highlighters.css because of whitelist item {"sourceName":"/highlighters\.css$/i","errorMessage":"/Unknown pseudo-class.*moz-native-anonymous/i","isFromDevTools":true,"used":true}
[task 2019-10-19T13:48:05.951Z] 13:48:05 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-native-anonymous’. Ruleset ignored due to bad selector." on resource://devtools/server/actors/highlighters.css because of whitelist item {"sourceName":"/highlighters\.css$/i","errorMessage":"/Unknown pseudo-class.*moz-native-anonymous/i","isFromDevTools":true,"used":true}
[task 2019-10-19T13:48:05.951Z] 13:48:05 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-native-anonymous’. Ruleset ignored due to bad selector." on resource://devtools/server/actors/highlighters.css because of whitelist item {"sourceName":"/highlighters\.css$/i","errorMessage":"/Unknown pseudo-class.*moz-native-anonymous/i","isFromDevTools":true,"used":true}
[task 2019-10-19T13:48:05.951Z] 13:48:05 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-native-anonymous’. Ruleset ignored due to bad selector." on resource://devtools/server/actors/highlighters.css because of whitelist item {"sourceName":"/highlighters\.css$/i","errorMessage":"/Unknown pseudo-class.*moz-native-anonymous/i","isFromDevTools":true,"used":true}
[task 2019-10-19T13:48:05.952Z] 13:48:05 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-native-anonymous’. Ruleset ignored due to bad selector." on resource://devtools/server/actors/highlighters.css because of whitelist item {"sourceName":"/highlighters\.css$/i","errorMessage":"/Unknown pseudo-class.*moz-native-anonymous/i","isFromDevTools":true,"used":true}
[task 2019-10-19T13:48:05.952Z] 13:48:05 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-native-anonymous’. Ruleset ignored due to bad selector." on resource://devtools/server/actors/highlighters.css because of whitelist item {"sourceName":"/highlighters\.css$/i","errorMessage":"/Unknown pseudo-class.*moz-native-anonymous/i","isFromDevTools":true,"used":true}
[task 2019-10-19T13:48:05.953Z] 13:48:05 INFO - Ignored error "Unknown pseudo-class or pseudo-element ‘-moz-native-anonymous’. Ruleset ignored due to bad selector." on resource://devtools/server/actors/highlighters.css because of whitelist item {"sourceName":"/highlighters\.css$/i","errorMessage":"/Unknown pseudo-class.*moz-native-anonymous/i","isFromDevTools":true,"used":true}
[task 2019-10-19T13:48:05.953Z] 13:48:05 INFO - Buffered messages finished
[task 2019-10-19T13:48:05.954Z] 13:48:05 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/static/browser_parsable_css.js | Got error message for resource://devtools/client/webconsole/components/App.css: Unknown property ‘rotate’. Declaration dropped. -
[task 2019-10-19T13:48:05.954Z] 13:48:05 INFO - Stack trace:
[task 2019-10-19T13:48:05.954Z] 13:48:05 INFO - chrome://mochikit/content/browser-test.js:test_ok:1297
[task 2019-10-19T13:48:05.954Z] 13:48:05 INFO - chrome://mochitests/content/browser/browser/base/content/test/static/browser_parsable_css.js:messageIsCSSError:282
[task 2019-10-19T13:48:05.954Z] 13:48:05 INFO - chrome://mochitests/content/browser/browser/base/content/test/static/browser_parsable_css.js:checkAllTheCSS:503
[task 2019-10-19T13:48:05.955Z] 13:48:05 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-10-19T13:48:05.955Z] 13:48:05 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/static/browser_parsable_css.js | All the styles (182) loaded without errors. - Got 1, expected 0
[task 2019-10-19T13:48:05.955Z] 13:48:05 INFO - Stack trace:
[task 2019-10-19T13:48:05.955Z] 13:48:05 INFO - chrome://mochikit/content/browser-test.js:test_is:1312
[task 2019-10-19T13:48:05.955Z] 13:48:05 INFO - chrome://mochitests/content/browser/browser/base/content/test/static/browser_parsable_css.js:checkAllTheCSS:504
[task 2019-10-19T13:48:05.955Z] 13:48:05 INFO - Leaving test bound checkAllTheCSS
[task 2019-10-19T13:48:05.955Z] 13:48:05 INFO - GECKO(2940) | MEMORY STAT | vsize 747MB | vsizeMaxContiguous 740MB | residentFast 235MB | heapAllocated 121MB
[task 2019-10-19T13:48:05.955Z] 13:48:05 INFO - TEST-OK | browser/base/content/test/static/browser_parsable_css.js | took 545ms
[task 2019-10-19T13:48:05.955Z] 13:48:05 INFO - checking window state

Nicolas can you please take a look?

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: General → Console
Product: Firefox → DevTools
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Flags: needinfo?(nchevobbe)

The rotate property is only enabled on Nightly.
For beta, we need to use transform: rotate instead.

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/99b184e791f9
Fix browser_parsable_css.js failure on beta. r=Honza.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

Comment on attachment 9102807 [details]
Bug 1589867 - Fix browser_parsable_css.js failure on beta. r=Honza.

Beta/Release Uplift Approval Request

  • User impact if declined: no user impact, but test is failing on beta branch
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): small CSS change to fix a test failures
  • String changes made/needed:
Flags: needinfo?(nchevobbe)
Attachment #9102807 - Flags: approval-mozilla-beta?

Comment on attachment 9102807 [details]
Bug 1589867 - Fix browser_parsable_css.js failure on beta. r=Honza.

Minimal css fix with, low risk, approved for 71 beta 4, thanks.

Attachment #9102807 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.