Closed Bug 1590387 Opened 1 year ago Closed 1 year ago

Remove remaining usages of XUL textboxes (old cert viewer broken)

Categories

(Toolkit :: XUL Widgets, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla72
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 + verified
firefox72 --- verified

People

(Reporter: ntim, Assigned: ntim)

References

Details

(Keywords: perf-alert)

Attachments

(1 file)

We forgot to catch these apparently: https://searchfox.org/mozilla-central/search?q=%3Cxul%3Atextbox&path= :)

Johann, is the old cert viewer something we're still shipping in 71 ?

Brian, do you think you could find someone to look at the tests ?

Flags: needinfo?(jhofmann)
Flags: needinfo?(bgrinstead)

(In reply to Tim Nguyen :ntim from comment #0)

We forgot to catch these apparently: https://searchfox.org/mozilla-central/search?q=%3Cxul%3Atextbox&path= :)

Johann, is the old cert viewer something we're still shipping in 71 ?

Brian, do you think you could find someone to look at the tests ?

Yes, unfortunately. It's fully behind a pref but we don't want to remove the code in 71 yet. However, it's very unlikely to be used, so we can probably go with the cheapest solution that works.

Flags: needinfo?(jhofmann)

Thanks Johann! I'll take this one then.

Assignee: nobody → ntim.bugs

I actually intentionally marked this as defect as it totally breaks the old cert viewer.

Type: task → defect
Summary: Remove remaining usages of XUL textboxes → Remove remaining usages of XUL textboxes (old cert viewer broken)
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/f748a3d2cdf1
Remove remaining usages of XUL textboxes. r=bgrins
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
Duplicate of this bug: 1590612

Comment on attachment 9103254 [details]
Bug 1590387 - Remove remaining usages of XUL textboxes. r=bgrins

Beta/Release Uplift Approval Request

  • User impact if declined: Old certificate Viewer (enabled by default on 71) is broken.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Open cert viewer, see attachment 9103410 [details]
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Trivial XUL+CSS change that was manually tested.
  • String changes made/needed: no
Attachment #9103254 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Let's have it in Nightly and verified by QA before uplifting.

Duplicate of this bug: 1590719

Here are some more precise verification steps for Nightly:

  • Set security.aboutcertificate.enabled to false
  • Go to https://www.mozilla.org/en-US/
  • Right click and click "View Page Info"
  • Go to the "Security" tab
  • Click "View Certificate"
  • See the broken cert viewer
QA Whiteboard: [qa-triaged]

Comment on attachment 9103254 [details]
Bug 1590387 - Remove remaining usages of XUL textboxes. r=bgrins

Fix for certificate viewer broken in 71, uplift approved for 71 beta 4, let's have QA verify the fix on beta.

Attachment #9103254 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Hello! Reproduced the issue using STR from comment 11 with Firefox 72.0a1 (20191022214314) on Windows 10x64.
The issue is verified fixed using Firefox 72.0a1 (20191023215406) and 71.0b4 (20191024095932) from comment 13 on Windows 10x64, macOS 10.14 and Ubuntu 18.04. The "Certificate Viewer" is correctly shown.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.