If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

difference in parsing of html produced by xslt and normal html

RESOLVED DUPLICATE of bug 130161

Status

()

Core
XSLT
RESOLVED DUPLICATE of bug 130161
15 years ago
15 years ago

People

(Reporter: paul stanton, Assigned: peterv)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
compare the two pages:
http://gruden.com/paul_stanton/links/links.xml
http://gruden.com/paul_stanton/links/links.html

note: the .html file was generated using the dom inspector's 'Copy XML' function
on the .xml

two problems:
1. links.html: extra whitespace is being inserted into the <a> tags after the text
eg: <a>blah</a> becomes <a>blah   </a>

2. links.xml: the css class used on the body tag has a background-color which in
the .html version fills the whole window, in the .xml version however, it only
fills upto where text is rendered.

Also, i had to remove a javascript i had running at the bottom of the page
because in the xml version, i would get a javascript error 'document.writeln is
not a function' or something. does this mean that the javascript engine is not
available until after page load?
(Assignee)

Comment 1

15 years ago
How does this relate to XSLT? I don't see a reference to an XSLT stylesheet
anywhere. Most of your problems seem to come from the fact that giving the file
the xml suffix makes Mozilla interpret it as XHTML.
(Assignee)

Comment 2

15 years ago
Oh, hmm. I see now. Transformiix generates XHTML for output="html". If you keep
that in mind when writing the transformation, things start to make sense.

*** This bug has been marked as a duplicate of 130161 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

15 years ago
please explain? sorry to have lumped 3 problems in one bug, but which are you
referring to and what do you mean? thansk.
(Assignee)

Comment 4

15 years ago
2 and 3. DOM Inspector is not XSLT.
2: you need to set the background color on the html element.
3: document.writeln doesn't work for XHTML iirc.
You need to log in before you can comment on or make changes to this bug.