Closed Bug 1590680 Opened 3 months ago Closed 3 months ago

Perma fission AttributeError: 'NoneType' object has no attribute 'append'

Categories

(Firefox :: General, defect, P5)

defect

Tracking

()

RESOLVED FIXED
Firefox 72
Fission Milestone M4
Tracking Status
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: ahal)

References

(Regression)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: apavel [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=272539904&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/LJ7L44PpTWqMzty0O-SBLg/runs/0/artifacts/public/logs/live_backing.log


[task 2019-10-23T09:56:41.462Z] 1:08.15 0:02.15 File already read. Skipping: /builds/worker/checkouts/gecko/gfx/angle/targets/angle_common/moz.build
[task 2019-10-23T09:56:54.104Z] 1:20.79 Finished reading 1781 moz.build files in 3.74s
[task 2019-10-23T09:56:54.104Z] 1:20.79 Read 64 gyp files in parallel contributing 0.13s to total wall time
[task 2019-10-23T09:56:54.104Z] 1:20.79 Processed into 11036 build config descriptors in 4.06s
[task 2019-10-23T09:56:54.104Z] 1:20.79 RecursiveMake backend executed in 5.82s
[task 2019-10-23T09:56:54.105Z] 1:20.79 3864 total backend files; 3864 created; 0 updated; 0 unchanged; 0 deleted; 32 -> 1432 Makefile
[task 2019-10-23T09:56:54.105Z] 1:20.79 FasterMake backend executed in 0.44s
[task 2019-10-23T09:56:54.105Z] 1:20.80 12 total backend files; 12 created; 0 updated; 0 unchanged; 0 deleted
[task 2019-10-23T09:56:54.105Z] 1:20.80 Total wall time: 14.79s; CPU time: 14.39s; Efficiency: 97%; Untracked: 0.72s
[task 2019-10-23T09:56:54.522Z] Configure complete!
[task 2019-10-23T09:56:54.522Z] Be sure to run |mach build| to pick up any changes
[task 2019-10-23T09:56:54.522Z] Finding tests...
[task 2019-10-23T09:56:54.522Z] Error running mach:
[task 2019-10-23T09:56:54.523Z]
[task 2019-10-23T09:56:54.523Z] ['test-info', 'report', '--show-tests', '--show-summary', '--filter-keys=fail-if,skip-if', '--filter-values=(?<!!)fission', '--output-file', '/builds/worker/artifacts/test-info-fission.json']
[task 2019-10-23T09:56:54.523Z]
[task 2019-10-23T09:56:54.523Z] The error occurred in code that was called by the mach command. This is either
[task 2019-10-23T09:56:54.523Z] a bug in the called code itself or in the way that mach is calling it.
[task 2019-10-23T09:56:54.523Z] You can invoke |./mach busted| to check if this issue is already on file. If it
[task 2019-10-23T09:56:54.523Z] isn't, please use |./mach busted file| to report it. If |./mach busted| is
[task 2019-10-23T09:56:54.523Z] misbehaving, you can also inspect the dependencies of bug 1543241.
[task 2019-10-23T09:56:54.523Z]
[task 2019-10-23T09:56:54.523Z] If filing a bug, please include the full output of mach, including this error
[task 2019-10-23T09:56:54.523Z] message.
[task 2019-10-23T09:56:54.523Z]
[task 2019-10-23T09:56:54.523Z] The details of the failure are as follows:
[task 2019-10-23T09:56:54.523Z]
[task 2019-10-23T09:56:54.523Z] AttributeError: 'NoneType' object has no attribute 'append'
[task 2019-10-23T09:56:54.523Z]
[task 2019-10-23T09:56:54.523Z] File "/builds/worker/checkouts/gecko/testing/mach_commands.py", line 1277, in test_report
[task 2019-10-23T09:56:54.523Z] subsuite=subsuite))
[task 2019-10-23T09:56:54.523Z] File "/builds/worker/checkouts/gecko/testing/mozbase/moztest/moztest/resolve.py", line 637, in resolve_tests
[task 2019-10-23T09:56:54.523Z] for test in self._resolve(**kwargs):
[task 2019-10-23T09:56:54.523Z] File "/builds/worker/checkouts/gecko/testing/mozbase/moztest/moztest/resolve.py", line 463, in _resolve
[task 2019-10-23T09:56:54.523Z] self.add_puppeteer_manifest_data()
[task 2019-10-23T09:56:54.523Z] File "/builds/worker/checkouts/gecko/testing/mozbase/moztest/moztest/resolve.py", line 509, in add_puppeteer_manifest_data
[task 2019-10-23T09:56:54.523Z] self._tests.append({
[fetches 2019-10-23T09:56:54.542Z] removing /builds/worker/fetches
[fetches 2019-10-23T09:56:55.482Z] finished
[taskcluster 2019-10-23 09:56:55.876Z] === Task Finished ===
[taskcluster 2019-10-23 09:56:55.981Z] Artifact "public" not found at "/builds/worker/artifacts"
[taskcluster 2019-10-23 09:56:56.478Z] Unsuccessful task run with exit code: 1 completed in 161.079 seconds

Kashav can this be from bug 1578465?

Flags: needinfo?(kmadan)

(In reply to Andreea Pavel [:apavel] from comment #1)

Kashav can this be from bug 1578465?

Very unlikely, this happens before a single test even runs. Looks like it could be related to bug 1583353 though.

Flags: needinfo?(kmadan)

Andrew any insight?

Flags: needinfo?(ahal)

Yes, this looks like it's my fault. I'll get a fix landed asap. Thanks!

Assignee: nobody → ahal
Status: NEW → ASSIGNED
Flags: needinfo?(ahal)
Regressed by: 1583353

Thank you!

Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9e5d727b7983
[moztest.resolve] Fix edge case where puppeteer/wpt manifest data is requested before the main tests, r=gbrown
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
Regressions: 1591512

Retroactively moving fixed bugs whose summaries mention "Fission" (or other Fission-related keywords) but are not assigned to a Fission Milestone to an appropriate Fission Milestone.

This will generate a lot of bugmail, so you can filter your bugmail for the following UUID and delete them en masse:

0ee3c76a-bc79-4eb2-8d12-05dc0b68e732

Fission Milestone: --- → M4
You need to log in before you can comment on or make changes to this bug.