Closed Bug 1591608 Opened 4 months ago Closed 4 months ago

Replace the naming for media control keys event related classes with more generic name

Categories

(Core :: Audio/Video: Playback, task, P2)

task

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox72 --- fixed

People

(Reporter: alwu, Assigned: alwu)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Now there are some classes using the naming of MediaHardwareKeysXXX. However, the media control key events can come from either physical devices, such as a keyboard or a headset, or from virtual interface, such as SMTC-based visual controller on Windows or MPRIS-based visual controller on Linux.

Therefore, we would be better to rename all those MediaHardwareKeysXXX to MediaControlKeysXXX in order to represent a generic concept.

The media control key events can come from either physical devices, such as a keyboard or a headset, or from virtual interface, such as SMTC-based visual controller on Windows or MPRIS-based visual controller on Linux.

Therefore, we would be better to rename all those MediaHardwareKeysXXX to MediaControlKeysXXX in order to represent a generic concept.

File's name should reflect what the class is inside the file.

Blocks: 1591620
Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/653caae61e4f
part1 : rename `MediaHardwareKeysXXX` to `MediaControlKeysXXX`. r=chunmin
https://hg.mozilla.org/integration/autoland/rev/22402bfc5b48
part2 : rename files from 'MediaHardwareKeysXXX' to 'MediaControlKeysXXX'. r=chunmin
https://hg.mozilla.org/integration/autoland/rev/9be89065895f
part3 : follow the new naming rule for define guards. r=chunmin
You need to log in before you can comment on or make changes to this bug.