Closed Bug 1591791 Opened 5 months ago Closed 5 months ago

Port |Bug 1584809 - PageInfo cookie permissions default to allow| to SeaMonkey

Categories

(SeaMonkey :: Page Info, defect)

defect
Not set

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 affected, seamonkey2.57esr fixed)

RESOLVED FIXED
seamonkey2.69
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- affected
seamonkey2.57esr --- fixed

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

At the moment for pageInfo cookie permissions, if Services.perms.testPermissionFromPrincipal(gPermPrincipal, "cookie") returns SitePermissions.UNKNOWN then the radio group is set to have nothing selected.
When the checkbox is unchecked, the radio group is tested and if it has nothing selected then the assumption is that the permission should be #1 i.e. ALLOW_ACTION
It should be the default for the relevant permission

Attached patch Use getDefaultSplinter Review

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: Unexpected behaviour if default is set to something other than allow
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: None

Attachment #9104502 - Flags: review?(frgrahl)
Attachment #9104502 - Flags: approval-comm-release?
Attachment #9104502 - Flags: approval-comm-esr60?
Comment on attachment 9104502 [details] [diff] [review]
Use getDefault

LGTM
Attachment #9104502 - Flags: review?(frgrahl)
Attachment #9104502 - Flags: review+
Attachment #9104502 - Flags: approval-comm-release?
Attachment #9104502 - Flags: approval-comm-release+
Attachment #9104502 - Flags: approval-comm-esr60?
Attachment #9104502 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/f1b5416c152b
Port |Bug 1584809 - PageInfo cookie permissions default to allow| to SeaMonkey. r=frg DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.