Closed Bug 1592509 Opened 2 years ago Closed 2 years ago

Enable gfx.webrender.compositor by default on Windows

Categories

(Core :: Graphics: WebRender, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla74
Tracking Status
firefox73 --- disabled
firefox74 --- fixed

People

(Reporter: sotaro, Assigned: sotaro)

References

(Blocks 2 open bugs, Regressed 3 open bugs)

Details

Attachments

(1 file, 1 obsolete file)

Bug 1591004 is not enough for enabling os compositor on Windows.

Depends on: 1591004
Depends on: 1591758
Depends on: 1592026
Depends on: 1585619
Depends on: 1592510
Depends on: 1592512
Blocks: wr-perf
Priority: -- → P3
Depends on: 1593319
Depends on: 1595965
Depends on: 1595437
Depends on: 1597559
Depends on: 1599673
Depends on: 1600501
No longer depends on: 1592026
Assignee: nobody → sotaro.ikeda.g
Pushed by sikeda.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c12330a620c4
Enable gfx.webrender.compositor by default on Windows r=gw
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
Regressions: 1602511
Depends on: 1602643
Regressions: 1603015
Regressions: 1603083
See Also: → 1603325

For posterity, bug 1604088 disabled this on m-c.

Depends on: 1604006
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #9114074 - Attachment is obsolete: true

Current WR compositor usage caused a lot of reftest failures that did not happen in Comment 5 :(
https://treeherder.mozilla.org/#/jobs?repo=try&revision=878b1344aba802158b04c87d8b07ab61faf3601f

Depends on: 1608741
Depends on: 1609913
Pushed by sikeda.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cd2634c753b9
Re-enable gfx.webrender.compositor by default on Windows r=gw,jrmuizel
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Regressions: 1611800
Regressions: 1615590

AFAICT this didn't make 73.

Target Milestone: mozilla73 → mozilla74

I have the dev version 75.0b11 installed. The about:support page indicates the following:
WEBRENDER_COMPOSITOR: blacklisted by runtime: Blacklisted

Screenshot: https://imgur.com/LzqF0ec

Why?! O__O In previous beta versions, everything was fine!!!
My graphics card is AMD Radeon RX Vega M GH.

(In reply to 5silentrain from comment #12)

I have the dev version 75.0b11 installed. The about:support page indicates the following:
WEBRENDER_COMPOSITOR: blacklisted by runtime: Blacklisted

Screenshot: https://imgur.com/LzqF0ec

Why?! O__O In previous beta versions, everything was fine!!!
My graphics card is AMD Radeon RX Vega M GH.

We're currently blocking DirectComposition in late beta and release on AMD hardware to minimize risk. We'll eventually turn it on AMD hardware.

You'll get DirectComposition again once beta switches to 76 or you could switch to using Nightly.

Okay! I will look forward to the 76th version 🙂 DirectComposition works on my graphics card (AMD Radeon RX Vega M GH) without any problems 👍

(In reply to Jeff Muizelaar [:jrmuizel] from comment #13)

(In reply to 5silentrain from comment #12)

I have the dev version 75.0b11 installed. The about:support page indicates the following:
WEBRENDER_COMPOSITOR: blacklisted by runtime: Blacklisted

Screenshot: https://imgur.com/LzqF0ec

Why?! O__O In previous beta versions, everything was fine!!!
My graphics card is AMD Radeon RX Vega M GH.

We're currently blocking DirectComposition in late beta and release on AMD hardware to minimize risk. We'll eventually turn it on AMD hardware.

You'll get DirectComposition again once beta switches to 76 or you could switch to using Nightly.

DirectComposition worked in version 76.0b5 👌 Today updated to version 76.0b6. DirectComposition does not work again 😫 The about:support page indicates the following: https://imgur.com/eIPN2no

That's bug 1631312.

(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #16)

That's bug 1631312.

So this is a bug? 🤨 Is it already fixed?

Yes. The "Tracking" section of bug 1631312 is expanded by default: It tells that this has been fixed in Nightly 77 (2 hours ago: bug 1631312 comment 4) and awaits a patch uplift to Beta 76 (affected + tracking requested). The "References" section tells that this was caused by bug 1630629 yesterday. The fix of bug 1630629 had not been verified in Nightly (bug 1630629 comment 5), so it was merged untested into Beta.

Today, Firefox has been updated to version 76.0b7. The bug is still present 😕

(In reply to 5silentrain from comment #19)

Today, Firefox has been updated to version 76.0b7. The bug is still present 😕

I'm pretty sure comment #16 is unrelated and comment #13 explains this. It'll be turned on on early beta (betas 1-5) each cycle and turned off in late beta (beta 6 and later) to be closer to what we release -- until there's a decision to release with it enabled on AMD hardware. Until that happens, if you want this enabled, we suggest you use nightly (as per comment #13).

Jeff, is there a separate bug on file on directcomposition enabling by default on release / late beta for AMD hardware users that people can follow?

5silentrain, out of interest, is there a particular reason why you need directcomposition to be enabled? What breaks or works poorly without it?

Flags: needinfo?(jmuizelaar)
Flags: needinfo?(5silentrain)

(In reply to :Gijs (he/him) from comment #20)

5silentrain, out of interest, is there a particular reason why you need directcomposition to be enabled? What breaks or works poorly without it?

The problem I described here appears: https://bugzilla.mozilla.org/show_bug.cgi?id=1591218
With DirectComposition enabled, everything starts working perfectly!

Flags: needinfo?(5silentrain)

You can open any video on YouTube in full screen mode and start pressing the Win key on the keyboard many times. If DirectComposition is disabled, this will lead to strong jerking of the video. At least this applies to my computer.

Also, the problem goes away if I force disable "WebRender" on the about:config page (the parameter "gfx.webrender.force-disabled"). In "Direct3D 11 (Advanced Layers)" mode, everything works fine 👌

This should get better with bug 1632239 which is landing now.

Flags: needinfo?(jmuizelaar)
Regressions: 1638709
Regressions: 1646786
Regressions: 1660865
You need to log in before you can comment on or make changes to this bug.