Closed Bug 1592685 Opened 4 months ago Closed 3 months ago

Add a new dynamic triplet on-boarding card for chrome switchers

Categories

(Firefox :: Messaging System, enhancement, P1)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1595842
Firefox 72
Iteration:
72.3 - Nov 18 - Dec 1
Tracking Status
firefox71 --- unaffected
firefox72 --- affected

People

(Reporter: pdahiya, Assigned: pdahiya)

References

(Depends on 1 open bug, Blocks 2 open bugs)

Details

Add a new dynamic triplet on-boarding card thats displayed based of attribution (Downloading Browser)

Blocks: 1591165
Assignee: nobody → pdahiya
Iteration: --- → 72.2 - Nov 4 - 17
Priority: -- → P1
Target Milestone: --- → Firefox 72

Hi Aaron, Jim do we have a link to invision for chrome switchers onboarding card? Thanks!

Flags: needinfo?(jimthomas)
Flags: needinfo?(abenson)

Hey Punam .. content is still pending for it but it has the same attributes as the other cards (image, headline, body text, button). If you wanted to just rough it up with fake content I think that would be okay for the interim.

Here's the mockup that has the catalog which will eventually be updated: https://mozilla.invisionapp.com/share/DXUCIZXA2C4#/screens/388344477_Contextual_Triplets

Flags: needinfo?(abenson)
Iteration: 72.2 - Nov 4 - 17 → 72.3 - Nov 18 - Dec 1

Link to update copy: https://docs.google.com/document/d/1GfMwLYHv10tHF7bV2hPhM6KxkmlL350g36FRpiWv9CA/edit

NI Aaron to help attach icon to be used in Chrome switchers card. Thanks!

Flags: needinfo?(jimthomas) → needinfo?(abenson)

We should bring in Chrome switcher card with UI similar to onboarding template cards such as
https://searchfox.org/mozilla-central/source/browser/components/newtab/lib/OnboardingMessageProvider.jsm#297

with strings from comment #3, a new icon, targeting as "trailheadTriplet == 'dynamic_chrome' && attributionData.browser == 'chrome'"

and order as 0 so that it shows at first place in dynamic chrome triplets branch

Submitting this fix as part of implementing import wizard from chrome switchers onboarding card CTA

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1595842
Flags: needinfo?(abenson)
Depends on: 1615344
You need to log in before you can comment on or make changes to this bug.