Closed Bug 1593455 Opened 2 years ago Closed 2 years ago

Converting ISO-8859-1 mails to Maildir corrupts german Umlaute

Categories

(Thunderbird :: Untriaged, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1515254

People

(Reporter: 85ta, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

I converted my local folders from mbox to maildir format. This worked fine for UTF-8 mails, but not for mails encoded with ISO 8859-1 or 8859-15 (which are most of my saved mails in local folders).

Actual results:

The mails are converted, but the german Umlaute ("umlauts") ä, ö, ü and ß are converted into nonsense sequences. They are not reparable by changing the mail encoding.

Expected results:

ä, ö, ü and ß should be the same after converting an mbox to maildir...

Likely a duplicate.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1515254
You need to log in before you can comment on or make changes to this bug.