The default bug view has changed. See this FAQ.

Scrollbar not working when moving mouse out and in again

RESOLVED FIXED in mozilla11

Status

()

Core
XUL
RESOLVED FIXED
15 years ago
2 years ago

People

(Reporter: jernej srebrnic, Assigned: masayuki)

Tracking

(Depends on: 1 bug)

Trunk
mozilla11
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [inbound])

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020724
BuildID:    2002072408

when you press the up or down arrow of the scroller bar it starts scrolling.
whit the mouse buton pressed move of the arrow and then reenter. the scroler
shoud scroll agein, but it doesn't

Reproducible: Always
Steps to Reproduce:
1. press the up or down arrow of the scroller bar
2. mouse button pressed move of the arrow
3. reenter whit the mouse button still pressed


Actual Results:  the scroller does not scroll

Expected Results:  should scroll when you reenter

the arrow is repainted in hte raight way. when you reeenter it presed, but with
no effect...
Confirmed on WinXP trunk build 2002072408.

-> XP Toolkit/Widgets
Assignee: sgehani → jaggernaut
Status: UNCONFIRMED → NEW
Component: XP Apps → XP Toolkit/Widgets
Ever confirmed: true
QA Contact: paw → jrgm
Summary: page scroller wrog beheivor → Scrollbar not working when moving mouse out and in again
OS: Windows XP → All
Hardware: PC → All

Comment 2

14 years ago
*** Bug 227716 has been marked as a duplicate of this bug. ***

Comment 3

9 years ago
This bug is now over 4 years old and it is still an issue in Firefox 3 beta 5. When will this finally be addressed?

Updated

8 years ago
Assignee: jag → nobody
(Assignee)

Updated

5 years ago
Assignee: nobody → masayuki
Status: NEW → ASSIGNED
QA Contact: jrgmorrison → xptoolkit.widgets
(Assignee)

Comment 4

5 years ago
Created attachment 574753 [details] [diff] [review]
Part.1 Scrollbar button should capture mouse events and do scroll only when cursor is on it
(Assignee)

Comment 5

5 years ago
Created attachment 574754 [details] [diff] [review]
Part.2 Repeat scroll even if mouse cursor is outside of the pressed scrollbar button on gtk2 and qt
(Assignee)

Comment 6

5 years ago
Created attachment 574755 [details] [diff] [review]
Part.3 Add new tests
(Assignee)

Comment 7

5 years ago
Note that the patches cannot emulate Mac's native behavior perfectly. On Mac, all scrollbar buttons of a scrollbar capture mouse events. When you move mouse cursor to the other scrollbar button, it scrolls the other direction. We should separate the bug for Mac later.
(Assignee)

Updated

5 years ago
Attachment #574753 - Flags: review?(enndeakin)
(Assignee)

Updated

5 years ago
Attachment #574754 - Flags: review?(roc)
Attachment #574754 - Flags: review?(enndeakin)
(Assignee)

Updated

5 years ago
Attachment #574755 - Flags: review?(enndeakin)

Updated

5 years ago
Attachment #574753 - Flags: review?(enndeakin) → review+

Updated

5 years ago
Attachment #574754 - Flags: review?(enndeakin) → review+

Updated

5 years ago
Attachment #574755 - Flags: review?(enndeakin) → review+
Attachment #574754 - Flags: review?(roc)
Attachment #574754 - Flags: review?(enndeakin)
Attachment #574754 - Flags: review+
(Assignee)

Comment 8

5 years ago
Roc:

Enn has reviewed the patch already. I'd like you to review the widget part.
(Assignee)

Comment 9

5 years ago
Comment on attachment 574754 [details] [diff] [review]
Part.2 Repeat scroll even if mouse cursor is outside of the pressed scrollbar button on gtk2 and qt

Looks like roc also +'ed to the patch accoding to the bug history but I'm not sure it. Roc, did you +'ed for it? Or just changed the reviewer to Enn?
Attachment #574754 - Flags: review?(enndeakin)
I r+ed it.
(Assignee)

Comment 11

5 years ago
Okay, thank you. I land them.
(Assignee)

Comment 12

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/08a6c9818f93
https://hg.mozilla.org/integration/mozilla-inbound/rev/c6706ccc5a82
https://hg.mozilla.org/integration/mozilla-inbound/rev/14327685e15b

try:
https://tbpl.mozilla.org/?tree=Try&usebuildbot=1&rev=84f711b6b2bd
Whiteboard: [inbound]
Target Milestone: --- → mozilla11
(Assignee)

Updated

5 years ago
Flags: in-testsuite+
https://hg.mozilla.org/mozilla-central/rev/14327685e15b
https://hg.mozilla.org/mozilla-central/rev/c6706ccc5a82
https://hg.mozilla.org/mozilla-central/rev/08a6c9818f93
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Depends on: 703774

Updated

2 years ago
Depends on: 1121505
You need to log in before you can comment on or make changes to this bug.