Closed Bug 1593959 Opened Last month Closed Last month

Introduce a visual gap between results

Categories

(Firefox :: Address Bar, task, P2)

task
Points:
3

Tracking

()

RESOLVED FIXED
Firefox 72
Iteration:
72.2 - Nov 4 - 17
Tracking Status
firefox72 --- fixed

People

(Reporter: mak, Assigned: harry)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

According to the spec, there should be a visual 6px empty gap between 30px tall rows.
We have a few concerns regarding the mousehover state of rows, because it may flicker too much when moving across rows with the gap in the middle.
So this is pending a discussion with UX.

The gap is to be considered a padding, so that mousehover on the gap will still style the result as hovered (but the selected and hovered states are not full height).

Keywords: blocked-ux
Priority: P3 → P2
Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 72.2 - Nov 4 - 17

Verdi was thinking to make an interactive mockup for this, so once we have a patch, before landing, we could make a try build and ask him to try if it's what he had in mind.

Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4ee2e15986b6
Introduce a visual gap between results. r=mak
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
Regressions: 1596357
Depends on: 1596357
No longer regressions: 1596357
You need to log in before you can comment on or make changes to this bug.