Closed Bug 1594062 Opened 11 months ago Closed 10 months ago

When using one-off search buttons from the keyboard, there's no way to distinguish engines with the same icon

Categories

(Firefox :: Address Bar, defect, P2)

defect
Points:
3

Tracking

()

VERIFIED FIXED
Firefox 72
Iteration:
72.3 - Nov 18 - Dec 1
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- wontfix
firefox71 --- wontfix
firefox72 --- verified

People

(Reporter: florian, Assigned: mak)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: access, regression, Whiteboard: [access-p2])

Attachments

(2 files)

Bug 1561894 removed the name of the selected one off search engine from the UI. If I have Wikipedia in multiple languages, there's no way to know which one I'm picking using the keyboard, I have to use the mouse to hover the icon.

Points: --- → 3
Flags: needinfo?(mverdi)
Keywords: blocked-ux
Priority: -- → P2
Duplicate of this bug: 1590628
Whiteboard: [access-p2]

For the search bar we can likely use the header to show the currently selected one-off name.
For the urlbar, if a search result is selected it has a "- Search with <Engine>" suffix, that changes when selecting different one-offs. So the problem seems to only affect url results, and I'm not sure that's a critical problem because it's less likely to search for urls.

If we'd fix the search bar, this bug would probably be less critical.
Thoughts?

Flags: needinfo?(florian)

(In reply to Marco Bonardo [:mak] from comment #2)

For the search bar we can likely use the header to show the currently selected one-off name.

That would work; but what was wrong with the previous solution (ie changing the string displayed above the set of one-off buttons) ?

For the urlbar, if a search result is selected it has a "- Search with <Engine>" suffix, that changes when selecting different one-offs.

That suffix gets hidden as soon as the row is no longer selected, so it's hidden when selecting a one-off. Also, selecting one-offs from the keyboard in the urlbar seems pretty difficult. The only way I found is to press the down arrow several times to go through all the suggestions and history results.

Flags: needinfo?(florian)

(In reply to Florian Quèze [:florian] from comment #3)

(In reply to Marco Bonardo [:mak] from comment #2)

For the search bar we can likely use the header to show the currently selected one-off name.

That would work; but what was wrong with the previous solution (ie changing the string displayed above the set of one-off buttons) ?ù

It was a purely UX decision.
In the urlbar it's no more above the buttons, it's inline now; it would move the buttons around if we'd update the string.
The searchbar just followed to simplify the implementation and maintenance, and it's the place where we can easily fix this problem because it still has the header. The search bar is not our primary target anyway, its usage is declining constantly.

For the urlbar, if a search result is selected it has a "- Search with <Engine>" suffix, that changes when selecting different one-offs.

That suffix gets hidden as soon as the row is no longer selected, so it's hidden when selecting a one-off.

yes, selecting with up, down has that problem, selecting with ALT+DOWN/UP doesn't. We could evaluate to keep the "search with" text in the first result if a one-off button is selected.

Also, selecting one-offs from the keyboard in the urlbar seems pretty difficult. The only way I found is to press the down arrow several times to go through all the suggestions and history results.

ALT+DOWN or just UP should work, the former is totally undiscoverable though.
There's Bug 1437524 where we discussed about the possibility to use TAB to toggle between one-off buttons and results, but there's some resistance against such a change, because Chrome also supports TAB to move through results.
We also have a new Search button, under design now, that maybe could help a bit here, but we really need UX brainstorming about all the discoverability and navigation problem of one-off buttons.

In the meanwhile we can fix the search bar and urlbar with the above suggestions:

  1. use the header in the search bar
  2. don't hide the "- Search with" suffix if a one-off is selected

(In reply to Marco Bonardo [:mak] from comment #4)

ALT+DOWN or just UP should work, the former is totally undiscoverable though.

I actually didn't know about it! I thought ALT+up/down changed the default engine.

In the meanwhile we can fix the search bar and urlbar with the above suggestions:

  1. use the header in the search bar
  2. don't hide the "- Search with" suffix if a one-off is selected

Yeah, I think that would work and provide a consistent user experience.

Assignee: nobody → mak
Status: NEW → ASSIGNED
Iteration: --- → 72.3 - Nov 18 - Dec 1

(In reply to Florian Quèze [:florian] from comment #5)

ALT+DOWN or just UP should work, the former is totally undiscoverable though.

I actually didn't know about it! I thought ALT+up/down changed the default engine.

That only happens in the search bar with CTRL+UP/DOWN and imo it's not great, it's another undiscoverable feature that moreover changes things permanently. We don't plan to port that to the urlbar, afaik.

Clearing ni on Verdi, we have a way out for now, the global design and search button is something he is already brainstorming.

Flags: needinfo?(mverdi)
Keywords: blocked-ux

When a one-off button is the only selection, and the heuristic result is the
a search, forcibly show its action text, so the search engine name is visible.

This doesn't handle cases where the heuristic results are not searches, because
it would be a lot more complex and involve heavy design changes. Those cases
should be less common, representing searches for urls or non-search strings on
other engines.

Depends on D53784

Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/7f80960886b9
searchbar part  - When selecting a one-off button with the keyboard, update the searchbar header accordingly. r=Standard8
https://hg.mozilla.org/integration/autoland/rev/44bb8023055c
urlbar part - When selecting a one-off button with the keyboard, show action text on a search heuristic result. r=Standard8
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

We're building the final Fx71 beta before next week's RC tomorrow (Thursday). Is this something we should consider uplifting at this point in the cycle?

Flags: needinfo?(mak)
Flags: in-testsuite+

The timeline looks a bit strict, the patch is not particularly scary but I couldn't check it before tomorrow.
I don't think the bug is particularly critical, it's surely an annoyance, but doesn't really break functionality.

Flags: needinfo?(mak)

We have shipped our last beta for 71, since we have a patch in 72, I am setting 71 as fix-optional in case a safe fix could be uplifted as a ridealong in a dot release.

I reproduced this issue using Fx 72.0a1 (2019-10-22), on Windows 10 x64.
I can confirm this issue is fixed. I verified using Fx 73.0a1 and Fx 72.0b11, on Windows 10 x64, Ubuntu 18.04 LTS and macOS 10.13.6.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.