Closed Bug 1594162 Opened 1 year ago Closed 1 year ago

Blank tabs are shown after Firefox updated to version 71.0b7

Categories

(Firefox :: Session Restore, defect, P1)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 73
Tracking Status
firefox-esr68 --- wontfix
firefox70 --- wontfix
firefox71 - wontfix
firefox72 --- wontfix
firefox73 --- verified

People

(Reporter: pablo.muir, Assigned: jkt)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression)

Attachments

(3 files)

[Description:]

Blank tabs are shown after Firefox updated to version 71.0b7
From version 50.0b2 (zh-CN ) to 56.0b3 it is ok
from version 56.0b3 (zh-CN) to 71.0b7 it shows 2 blank tabs.

[Steps to reproduce:]

[Actual results]:
Previously open tabs are now showing all white, without data

[Expected results:]
Open tabs Should show data after restart

NOTE:
the links on those 2 tabs are:

https://support.mozilla.org/zh-CN/kb/how-change-your-default-browser-windows-10?utm_source=firefox-browser&utm_medium=firefox-browser&utm_campaign=redirect&utm_content=windows10-welcome-tab

https://start.firefoxchina.cn

by clicking on those links and hitting [enter key] the information appears on the screen.

On MacOs & Ubuntu: Only the tab with https://start.firefoxchina.cn showed empty.

TESTED ON:

Windows 10 64bit updating 50.0b2 (zh-CN localization) to latest version
Ubuntu 18.04 64bit updating 50.0b2 (zh-CN localization) to latest version
MacOS 10.14 updating 50.0b2 (zh-CN localization) to latest version

Attached image bugupdate1.jpg

Does this happen again if you restart the browser after updating it, or does the bug only reproduce on the restart that applies the update?

Flags: needinfo?(pablo.muir)

Hi Molly
I saw 2 things.

  1. 50.0b2 (zh-CN ) to 56.0b3 (zh-CN) to 71.0b7
    If i restart the browser one more time as you asked, i see the https://start.firefoxchina.cn/ tab only and i see the site properly

but

  1. 50.0b2 (zh-CN ) to 56.0b3 (zh-CN) to 71.0b7 + enable restore previous session in about:preferences when its on 71.0b7.
    If i restart the browser one more time at the end of the process, both tabs ares still blank

regards
Pablo

Flags: needinfo?(pablo.muir)

Okay, thanks for checking that. It sounds like something is going on with the session restore, not the update itself.

Component: Application Update → Session Restore
Product: Toolkit → Firefox

The priority flag is not set for this bug.
:mikedeboer, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(mdeboer)

Hi Pablo, any chance you could help run mozregression tool to find which commit fixed this issue in 72? Thank you.

Flags: needinfo?(pablo.muir)

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression

(In reply to Hsin-Yi Tsai [:hsinyi] from comment #6)

Hi Pablo, any chance you could help run mozregression tool to find which commit fixed this issue in 72? Thank you.

I overlooked the comment and got something wrong. Sorry!

Flags: needinfo?(pablo.muir)

Wontfix 71 and untracking as this looks like an edge case and we are in RC week, even if an investigation was successful and a fix were found, it would be too late for the release.

Attached image Nov26-Bug 1594162

I tried to reproduce the symptom on several platforms.
I can reproduce it on Win-10 32 bit in the virtalbox.

Here is the log from BrowserConsole.

Only the following error is from session restore component.
"Attempt to set a remote URL https://... as a tab icon without a loading principal."
This error only causes the icon is not set.
It is what we see in attachment 9106686 [details].
There is no icon on the left side of the tab.
Also, it won't stop restoring.

We may also want someone to take a look at other errors and exceptions in this case.

If QA can reproduce the symptom, please also attach the related log for investigating.
Thanks.

I load my reproduced sessionStore file in my local build and found that it is similar to bug 1500114.
The symptom is almost the same.
For my sessionStore file, the sessionHistory entry we want to restore doesn't have a "triggering principal".

Here we update FF from Beta 50.0b2 to 56.0b3. Then from 56.0b3. to 71.0b7.

I think it is a regression of bug 1521878.
By STR, the sessionStore we collect is from Beta 50.0b2 or 56.0b3.
There is a possibility that there is no "entry.triggeringPrincipal_base64".
In this case, we should assign a null principal to shEntry.triggeringPrincipal.

We have this logic before bug 1521878.

[Now]
https://searchfox.org/mozilla-central/rev/cce8b90aece0f42e5025e45282de16066eeaa662/toolkit/modules/sessionstore/SessionHistory.jsm#514

[before bug 1521878]
if (entry.triggeringPrincipal_base64) {
shEntry.triggeringPrincipal = E10SUtils.deserializePrincipal(entry.triggeringPrincipal_base64);
}
// Ensure that we have a null principal if we couldn't deserialize it.
// This won't always work however is safe to use.
if (!shEntry.triggeringPrincipal) {
debug("Couldn't deserialize the triggeringPrincipal, falling back to NullPrincipal");
shEntry.triggeringPrincipal = Services.scriptSecurityManager.createNullPrincipal({});
}

Depends on: 1500114
Flags: needinfo?(mdeboer) → needinfo?(jkt)
Regressions: 1521878

(In reply to Alphan Chen [:alchen] from comment #13)

[before bug 1521878]
if (entry.triggeringPrincipal_base64) {
shEntry.triggeringPrincipal = E10SUtils.deserializePrincipal(entry.triggeringPrincipal_base64);
}
// Ensure that we have a null principal if we couldn't deserialize it.
// This won't always work however is safe to use.
if (!shEntry.triggeringPrincipal) {
debug("Couldn't deserialize the triggeringPrincipal, falling back to NullPrincipal");
shEntry.triggeringPrincipal = Services.scriptSecurityManager.createNullPrincipal({});
}

By the way, I've verified my sessionStore with the original logic.
The tab works normally.

Is 72 actually not affected (which is what the status flag says) ?

Flags: needinfo?(alchen)
Assignee: nobody → jkt
Flags: needinfo?(jkt)

(In reply to :Gijs (he/him) from comment #15)

Is 72 actually not affected (which is what the status flag says) ?

I would say it is also affected.

Flags: needinfo?(alchen)

You are right that if condition shouldn't have ever been there. Checking in try, it's probably safe enough for an uplift also.

The priority flag is not set for this bug.
:mikedeboer, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(mdeboer)

:jkt, since this bug is a regression, could you fill (if possible) the regressed_by field?
For more information, please visit auto_nag documentation.

Flags: needinfo?(jkt)
Flags: needinfo?(jkt)
Regressed by: 1521878
No longer regressions: 1521878
See Also: → 1599368

Did you see my comment in Phab?

Flags: needinfo?(gijskruitbosch+bugs)

I responded on phab.

Flags: needinfo?(gijskruitbosch+bugs)

We may wish to uplift this patch as it shouldn't have any adverse impacts and reduces the chance of unrestorable tabs.

Flags: needinfo?(mdeboer)
Priority: -- → P1

(In reply to Jonathan Kingston [:jkt] from comment #23)

We may wish to uplift this patch as it shouldn't have any adverse impacts and reduces the chance of unrestorable tabs.

I think if you land on nightly now, it'll be in 73; 72 has already had RC's spun. I don't think this issue (restoring from really old versions of Firefox) is common enough to warrant spinning another RC. Also, 72 is actually marked unaffected, though I have no idea why that is...

Pushed by jkingston@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2b6c32f8991e
Fix missing triggering principal from session restore. r=Gijs
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 73

Retested issue on Firefox Release, Beta , and Nightly
Using windows 10 64bit, Ubuntu 18.04 64bit and MacOs 10.14

Release:
Installed version 49 (zh-CN ) then updated to version 56, then updated to version 71 (showed blank tabs)> then updated to version 72 (showed blank tabs)

Beta:
Installed 50.0b2 (zh-CN ) > updated to 56.0b3 > then updated to v72 beta and shows blank tabs . Then updated to> 73.0b1 beta and shows tabs correctly.

Nightly:
Installed 51.0a1 (zh-CN ) then updated to> 56.0a1 > then updated to 74.0a1 : all tabs were always visible.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.