Closed Bug 1594210 Opened 3 years ago Closed 3 years ago

Prevent browsertime from running on mozilla-central

Categories

(Testing :: Raptor, defect, P1)

Version 3
defect

Tracking

(firefox-esr68 unaffected, firefox70 unaffected, firefox71 unaffected, firefox72 fixed)

RESOLVED FIXED
mozilla72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 --- fixed

People

(Reporter: sparky, Assigned: sparky)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

This bug is to disable browsertime on mozilla-central, it shouldn't be running there.

See Also: → 1594212

:tarek, this failure is probably caused by the 'mozilla-central' entry in the visual-metrics task definition since browsertime should only run on integration branches: https://dxr.mozilla.org/mozilla-central/source/taskcluster/ci/visual-metrics-dep/kind.yml#23

That said, will the failure in bug 1594212 also be on 'integration'?

Flags: needinfo?(tarek)

Hey, if the current browsertime jobs are running on central due to a bug then that should be fixed for sure but IMO we should leave the btime jobs running on central. It's important to run on the latest code where most people develop from, to catch issues with browsertime ASAP and as well before getting to beta, etc.

This patch prevents the visual-metrics tasks from scheduling browsertime tests on mozilla-central by removing the run-on-projects setting (setting it to []). The run-on-projects setting is now set during the visual-metrics transformation so that it is the same as the dependent task so it will only run on projects that the dependent task runs on. Also, this patch enables browsertime TP6-1 on mozilla-central for chrome, firefox and geckoview.

Here's a taskgraph diff of before and after this patch for a mozilla-central push: https://www.diffchecker.com/kUsEkbFl

Note that geckoview and android tests have been added, along with the firefox/chrome tests. The vismet tasks are still the same, but now they are there by design because the btime tests were scheduled. Previously, the vismet tasks caused the btime tests to get scheduled.

Try run with this patch: https://treeherder.mozilla.org/#/jobs?repo=try&revision=d8312bffa75a836213811ab5532a0fc9d2c06a30

New try run which includes changes to the chromedriver fetches to prevent linux failures when running btime on firefox: https://treeherder.mozilla.org/#/jobs?repo=try&tier=1%2C2%2C3&revision=aa7113cdda4432aa76574065247ccbcf4262aa09

Pushed by gmierz2@outlook.com:
https://hg.mozilla.org/integration/autoland/rev/64599da92fcc
Fix vismet and browsertime tasks on mozilla-central. r=perftest-reviewers,rwood
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
Assignee: nobody → gmierz2
Flags: needinfo?(tarek)
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.