Closed Bug 1594277 Opened 2 months ago Closed 17 days ago

Fix usage of nsIDocShellTreeItem in mozilla::a11y::nsAccUtils::GetDocAccessibleFor

Categories

(Core :: DOM: Navigation, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1572831
Fission Milestone M6

People

(Reporter: djvj, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [rm-docshell-tree-item:simple])

https://searchfox.org/mozilla-central/rev/8b7aa8af652f87d39349067a5bc9c0256bf6dedc/accessible/android/DocAccessibleWrap.cpp#29

Uses DocShell tree to get parent item and check its type against the current (child) DocShell's tree item.

This can be switched to using BrowsingContext and its ItemType.

Tentatively moving all bugs whose summaries mention "Fission" (or other Fission-related keywords) but are not assigned to a Fission Milestone to the "?" triage milestone.

This will generate a lot of bugmail, so you can filter your bugmail for the following UUID and delete them en masse:

0ee3c76a-bc79-4eb2-8d12-05dc0b68e732

Fission Milestone: --- → ?
Fission Milestone: ? → M6
Priority: -- → P2
Status: NEW → RESOLVED
Closed: 17 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1572831
You need to log in before you can comment on or make changes to this bug.