Closed Bug 1594417 Opened 2 years ago Closed 2 years ago

Flickering in about:addons when switching between panels

Categories

(Toolkit :: Add-ons Manager, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 --- verified

People

(Reporter: itiel_yn8, Assigned: mstriemer)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

This doesn't reproduce reliably on every Firefox session, but once this happens in a session, it's 100% reproducible.
The flickering is around the More Options button, displaying its contents briefly before disappearing.

See attached screencast.

Attached image Screencast

I also noticed this at one point but couldn't reproduce after a restart as well. Figured it was a local build issue, thanks for the report!

Assignee: nobody → mstriemer
Priority: -- → P1

(In reply to Mark Striemer [:mstriemer] from comment #2)

I also noticed this at one point but couldn't reproduce after a restart as well. Figured it was a local build issue, thanks for the report!

Well, I'm on a non-local build...
Did you have the browser toolbox open at that time, by any chance?

When the stylesheet needs to load for panel-list it is missing the rule to
hide the panel while it's closed. Move this style into the shadow DOM so
it's always present even if the other styles haven't loaded yet.

This was especially noticeable when the "Disable Cache" option was enabled
with the devtools open.

Ah, that appeared to be it! With the disable cache option checked it would load the stylesheet each time and render without the style to hide the panel.

Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dff542b772e5
Ensure panel-list is hidden when added to document r=Gijs
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72

Verified fixed on Windows PRO 10 64-bit and on macOS Catalina 10.15 with FF Nightly 72.0a1 (20191111215252).
Switching between the about:addons panels while devtools is open and the Disabled Cache Network option is checked/ unchecked did not reveal any flickering issues.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.