Closed Bug 1525175 Opened 10 months ago Closed Last month

[about:addons] Move header into HTML views

Categories

(Toolkit :: Add-ons Manager, task, P2)

task

Tracking

()

VERIFIED FIXED
mozilla72
Tracking Status
firefox67 --- wontfix
firefox72 --- verified

People

(Reporter: mstriemer, Assigned: mstriemer)

References

(Blocks 1 open bug, Regressed 3 open bugs)

Details

(Whiteboard: [feature-scope])

Attachments

(4 files)

Once all the views have been implemented the header can be moved into the HTML browser. It should include the same stuff we have now:

  • Search bar with label
  • Heading
  • Back button, when appropriate
  • More options menu
    • All the options that are currently in this thing
Whiteboard: [feature-scope]
Blocks: 1533795
No longer blocks: 1505924
Summary: Move header into HTML views → [about:addons] Move header into HTML views
Blocks: 1556776
No longer blocks: 1533795
Type: enhancement → task
Depends on: 1552518
Assignee: nobody → mstriemer
Attachment #9088421 - Attachment description: Bug 1525175 - Convert about:addons header to HTML r?rpl → Bug 1525175 - Part 1: Convert about:addons header to HTML r?rpl
Duplicate of this bug: 1500534
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/324327819649
Part 1: Convert about:addons header to HTML r=rpl,fluent-reviewers,flod
https://hg.mozilla.org/integration/autoland/rev/67788f01d30b
Part 2: Position panel-list elements based on triggering event r=rpl
https://hg.mozilla.org/integration/autoland/rev/8a261afd573a
Part 3: Move system message bars into HTML views r=rpl,fluent-reviewers,flod
Regressions: 1593438
Blocks: 1545346

Hello,

Will this fix require manual validation? If yes, please provide some steps to reproduce in order to correctly test it and also, please set the "qe-verify+" flag. Otherwise, could the "qe-verify-" flag be added? Thanks!

Flags: needinfo?(mstriemer)

There aren't any specific STR. The search box, gear menu and back button are now in the HTML document and should behave the same way as before.

Marking qe-verify- since there's nothing specific to test. If you're up for poking around at it that would be good though.

Flags: needinfo?(mstriemer) → qe-verify-
Regressions: 1593838
Regressions: 1593840
Regressions: 1594196

Gonna flip this to qe-verify+. We've spotted a few minor regressions and I wouldn't really expect anything major but it would be good to get the coverage in now rather than finding things later.

This changes the header of the page, which has the "gear" menu, search box and back button. It also changed how the menus are positioned (the new one on the gear menu and the old ones on the card [...] button).

This unfortunately means the area of possible regressions is quite large. If we can get some poking around in the menu and things it handles to look for some general regressions they would likely be caused by this patch.

Flags: qe-verify- → qe-verify+
Regressions: 1594392
Regressions: 1594417

Verified on Windows Pro 10 64-bit, Ubuntu 18.04.3 LTS and macOS Catalina 10.15 with FF 72.0a1 (20191110095330).
Checked in Nightly versus Beta:

  1. There are the same labels and functionality for the search bar for each section of about:addons (Recommandations, Extensions, Themes, Plugins).
  2. Section Headers, Enabled and Disabled categories and extension headers.
  3. Extension Details, Options, Permissions and Release Notes (which can take a couple of seconds to load) and Back button.
  4. Extension “More options” (three dots) button for both Disabled and Enabled extensions includes the appropriate Disable or Enabled, Remove, Options, Report and Manage options.
  5. More Options Wheel button options are listed are the same as in Beta and are functional.
  6. Checked for updates when: there are updates available, there aren't, "Update Add-ons automatically" is checked off/on.

I do have a question about the design of the Cog wheel menu, which in Firefox Beta or in previous Firefox Nightly versions also had an arrow indicating the drop down menu. Was that change intended?
Also, is there a workaround for obtaining the Add-on compatibility check message bar?

Flags: needinfo?(mstriemer)

Thanks!

(In reply to Miruna Curtean from comment #10)

I do have a question about the design of the Cog wheel menu, which in Firefox Beta or in previous Firefox Nightly versions also had an arrow indicating the drop down menu. Was that change intended?

The dropdown marker being gone was intentional.

Also, is there a workaround for obtaining the Add-on compatibility check message bar?

There were some message bars that could appear in the old header which should still be present (safe mode, and I thought compatibility checking). Do you have a screenshot of the one you're thinking of?

Flags: needinfo?(mstriemer) → needinfo?(mcurtean)
Regressions: 1593649

(In reply to Mark Striemer [:mstriemer] from comment #11)

There were some message bars that could appear in the old header which should still be present (safe mode, and I thought compatibility checking). Do you have a screenshot of the one you're thinking of?

In fact it was the compatibility checking I was referring to. I was looking through the "Move system message bars into HTML views" commit and there was where I encountered message bar and did not know how to verify it.

Flags: needinfo?(mcurtean)

Ah, you can trigger this by opening a browser console and running AddonManager.checkCompatibility = false.

I've performed further testing on Firefox 72.0a1 (20191120234543) on Windows Pro 10 64-bit, Ubuntu 18.04.3 LTS and macOS Catalina 10.15.
Verified that:
Cog menu and Options can be closed using the ESC key.
Manage (bug 1594392), Remove and Report extension from toolbar while Addons Manager page is open/ is not open.
Adding a temporary extension in about:debugging and checking that Enable/Disable, Remove, Report, Manage and Back button are working for temporarily loaded extensions.
Installing and testing on Arabian localized version and checking mirroring in headers, More options, Cog menu, Abuse report, Manage extension.
As this ticket still has an unresolved dependency, 1552518, I am just adding the testing update. The bug can be marked as verified after also testing and verifying that 1552518 has been fixed.

Bug 1552518 (find in page -> search bar) was fixed by this.

Thank you for resolving that. Based on verifying and closing the dependency and the previous testing performed I am marking this as Verified fixed.

Status: RESOLVED → VERIFIED
Duplicate of this bug: 1569669
You need to log in before you can comment on or make changes to this bug.