Closed Bug 1594979 Opened 8 months ago Closed 8 months ago

Logpoints fail to log with `frame is null`

Categories

(DevTools :: Debugger, defect, P2)

defect

Tracking

(firefox72 fixed)

RESOLVED FIXED
Firefox 72
Tracking Status
firefox72 --- fixed

People

(Reporter: Harald, Assigned: jlast)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

What were you doing?

  1. Opened Debugger on https://webflow.com/dashboard/welcome
  2. Enabled Mouse category in Event BPs, then Log
  3. Filled out the form

What happened?

No logs, TypeError: frame is null messages.js:248:23

Looks like the error is coming here: we assume that the message has a filename

https://searchfox.org/mozilla-central/source/devtools/client/webconsole/utils/messages.js#238-249

Right. When I pause on that page for mouse events, it pauses in a SOURCE

Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/acfd160d3998
Logpoints fail to log with `frame is null`. r=bhackett
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
Assignee: nobody → jlaster
Duplicate of this bug: 1592144
QA Whiteboard: [qa-72b-p2]
You need to log in before you can comment on or make changes to this bug.