Closed Bug 1595093 Opened 1 year ago Closed 1 year ago

Crash in [@ mozilla::gfx::DrawTargetRecording::DrawTargetRecording]

Categories

(Core :: Graphics, defect)

Unspecified
Windows 10
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 --- fixed

People

(Reporter: pascalc, Assigned: mattwoodrow)

References

(Regression)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug is for crash report bp-382d9499-2994-4fb3-a1b0-4600d0191108.

Top 10 frames of crashing thread:

0 xul.dll mozilla::gfx::DrawTargetRecording::DrawTargetRecording gfx/2d/DrawTargetRecording.cpp:224
1 xul.dll mozilla::gfx::Factory::CreateRecordingDrawTarget gfx/2d/Factory.cpp:424
2 xul.dll mozilla::gfx::PaintFragment::Record gfx/ipc/CrossProcessPaint.cpp:114
3 xul.dll mozilla::dom::WindowGlobalChild::RecvDrawSnapshot dom/ipc/WindowGlobalChild.cpp:359
4 xul.dll mozilla::dom::PWindowGlobalChild::OnMessageReceived ipc/ipdl/PWindowGlobalChild.cpp:548
5 xul.dll mozilla::dom::PContentChild::OnMessageReceived ipc/ipdl/PContentChild.cpp:8096
6 xul.dll void mozilla::ipc::MessageChannel::DispatchMessage ipc/glue/MessageChannel.cpp:2130
7 xul.dll mozilla::ipc::MessageChannel::MessageTask::Run ipc/glue/MessageChannel.cpp:2003
8 xul.dll mozilla::SchedulerGroup::Runnable::Run xpcom/threads/SchedulerGroup.cpp:295
9 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1225

59 crashes in buildid 20191107215315
Changelog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d271c572a9bcd008ed14bf104b2eb81949952e4c&tochange=7748cc7e9b63d86a40eb4799c0830172da579c84

Same cause as bug 1595395? (both seem to start with the same buildid and involve DrawSnapshot)

Flags: needinfo?(matt.woodrow)

This is a regression from bug 1576911, which started using DrawSnapshot for thumbnails.

We crash constructing a mozilla::gfx::DrawTargetRecording::DrawTargetRecording because aDT is nullptr.

Assignee: nobody → matt.woodrow
Flags: needinfo?(matt.woodrow)
Regressed by: 1576911
Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/859e84396f6d
Make sure we always have a valid software backend, regardless of what prefs the user sets. r=lsalzman
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
You need to log in before you can comment on or make changes to this bug.