Status

()

Core
Networking: Cache
RESOLVED DUPLICATE of bug 146285
16 years ago
16 years ago

People

(Reporter: Ian, Assigned: gordon)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I have been installing the latest Mozilla releases for the last year (at least) 
and it has happened several times where the browser fails to work correctly 
after the installation due to the cache problems. 

My latest problem was with the upgrade from Mozilla 1.1 Alpha to Mozilla 1.1 
Beta. After the installation a lot of the sites I normally go to ie 
(www.google.com) had a bunch of broken images. If I tried to view the image the 
browser showed and error similar to "the gif could not be displayed because it 
has errors". If it has errors in the cache - it should remove it from the cache 
and get it from the site (but that is another issue). I was only able to correct 
this by clearing my cache.

I was thinking that all this could be avoided if mozilla would empty the cache 
during/after the installation. This way the browser is starting fresh.

Comment 1

16 years ago
see bug 50559

Comment 2

16 years ago
installer knows nothing about profiles...
Assignee: dveditz → gordon
Component: Installer → Networking: Cache
QA Contact: bugzilla → tever
(Assignee)

Comment 3

16 years ago
When the cache changes format, we increment the cache version number which will
cause old caches to be cleared on startup.  However, if one of the cache clients
changes the format of the data they store in the cache, the cache service has no
way of deetecting this.  The cache clients should consider adding a verision
number for their data formats as well, so they can doom old cache entries when
they fetch them.

cc'ing darin & pav as http and imglib are most likely suspects for the image
problem mentioned in the original description.
see also bug 146285

Comment 5

16 years ago
HTTP has not changed its cache entry format.  The problem sounds a lot more like
data corruption to me, which begs the question... did you ever previously run
two instances of mozilla using the same profile?  That is no longer permitted
(since mozilla 1.0 I think), but if you happened to have an old version of
Netscape 6 running along side Mozilla, you could easily corrupt your disk cache.
(Reporter)

Comment 6

16 years ago
Sounds like the same problem as bug 146285

I did have multiple version of mozilla netscape 6+ running so that may be the 
problem.

The issue I have here is that it looks like mozilla detected that the cache was 
invalid because I tried to view the image directly by entering the url for the 
image and mozilla displayed the message similar to  "the gif could not be 
displayed because it has errors". If it detected that there was errors 
displaying the file could it not assume that the cache is corrupt and clean it? 
Or even it the error was changed to say something like "the gif could not be 
displayed because it has errors - this problem may be due to your cache being  
currupt would you like to clear your cache". I prefere the first option. Besides 
what I'm I going to do with a currupt cache? I will most likely clear it to fix 
the problem.
The correct solution is that NS should use a different Profile.
Mozilla use it's own profile Apllication Data/Mozilla and NS should use
application Data/Netscape.

But that is an already filed bug and it's invalid in bugzilla.
see also the release notes that you should no share a profile between NS and
Mozilla.
(Assignee)

Comment 8

16 years ago
I agree this sounds like a dup of bug 146285.  We will be looking at ways to
more gracefully recover from problems like this.  Thanks for reporting it.

*** This bug has been marked as a duplicate of 146285 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.