Closed Bug 159625 Opened 18 years ago Closed 18 years ago

standards mode on <!DOCTYPE doctype PUBLIC "-//W3C//DTD HTML 4.0 Transitional//DE">

Categories

(Core :: DOM: HTML Parser, defect)

x86
Linux
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 101600

People

(Reporter: bugzilla_kl, Assigned: harishd)

References

()

Details

Attachments

(1 obsolete file)

(from bug 159616)

this DTD let's us render in standards mode. Same for other otherwise valid
DOCTYPEs, which have a wrong lang-code at the end, like:

<!DOCTYPE doctype PUBLIC "-//W3C//DTD HTML 4.0 Transitional//nl">

*** This bug has been marked as a duplicate of 101600 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED

cookie.value can't be accessed when cookie.first defaults to "no" which causes
it to throw an exception.
This change makes it so we only access cookie.value when the cookie.first
actually returns a cookie.

Pushed by valentin.gosu@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/c1e961421fe1
Fix exception in cors-tester.py in WPT tests r=jgraham
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/20280 for changes under testing/web-platform/tests
Upstream web-platform-tests status checks passed, PR will merge once commit reaches central.

(In reply to Stefan Hindli [:stefan_hindli] from comment #7)

https://hg.mozilla.org/mozilla-central/rev/c1e961421fe1

It looks like the commit message for this had the wrong bug ID.

Flags: needinfo?(valentin.gosu)
Flags: needinfo?(james)
Upstream PR merged by moz-wptsync-bot

(In reply to Mathew Hodson from comment #8)

(In reply to Stefan Hindli [:stefan_hindli] from comment #7)

https://hg.mozilla.org/mozilla-central/rev/c1e961421fe1

It looks like the commit message for this had the wrong bug ID.

The correct bug was actually bug 1596251. Sorry about the typo.

Flags: needinfo?(valentin.gosu)
Flags: needinfo?(james)

Comment on attachment 9108982 [details]
Bug 159625 - Fix exception in cors-tester.py in WPT tests r=jgraham

Revision D53167 was moved to bug 1596251. Setting attachment 9108982 [details] to obsolete.

Attachment #9108982 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.