Lost bookmarks while organizing into folders

VERIFIED WORKSFORME

Status

SeaMonkey
Bookmarks & History
--
critical
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: riscky, Assigned: Pierre Chanial)

Tracking

({dataloss, qawanted})

Trunk
dataloss, qawanted
Dependency tree / graph
Bug Flags:
blocking1.3a -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Today I was organizing my bookmarks into folders. Once such task was moving all
the bugs I bookmarked for one reason into another into one folder. I created two
folders. One folder contained the organized bookmarks, which would just contain
other folder, and a folder I wished to move all my bugmarks to, I then opened
the container folder and started to root around for all the bugmarks. I selected
a bunch (about 10-15) dragged them over and kept on looking. When I was done
about 1/3 of the bookmarks where moved into the bugmarks folder. The other
bookmarks where gone for good.

Reproducible: Didn’t try again… fear of losing more bookmarks
Build ID: 2002072408
OS X: 10.1.5

Updated

16 years ago
Severity: normal → critical
Keywords: dataloss
Summary: Lose of bookmarks while organizing into folders → Lost bookmarks while organizing into folders

Comment 1

16 years ago
Riscky, you should probably try reproducing this using a new Mozilla user profile.
(Reporter)

Comment 2

16 years ago
Thats what I plan on doing when I have a tad more free time.
(Reporter)

Comment 3

16 years ago
Had some free time... with build 2002072803

I dumped a ton of links from various websites a 'normal' size bookmark list.

I then quit mozilla to make a back up of the bookmark.html file

I then made two folders, container and bug. The bug folder was inside the
container folder. I then opened the container folder in a new window and started
by moving a few links at time. This is where I started to notice some issues.
Moving bookmarks between one window and a second window produces random results.

Results I found...
1.) bugs folder moved outside of container window (once)
2.) link was copied between main list and container window (three times)
3.) link would never move from list in main window to folder in second window
4.) when moving link from main window to second window folder (container -->
bug) link would be moved directly under container folder in the hierarchy of the
original management window.

More testing will be needed.

Comment 4

16 years ago
Adding qawanted for further testing.
Keywords: qawanted

Comment 5

16 years ago
I moved bookmarks around within a single window for 5 minutes, and could not get
any problems.

With multiple windows it's easy...

1. Create a new profile
2. Select 'Manage Bookmarks'
3. Create a 'Foo' folder
4. Right-click Foo to open it as a separate window
5. Dink down the personal toolbar
6. Drag one of its links over to the Foo window. It bounces back. I believe the
expected behavior is that it should move the link. The data is still in a good
state at this point.
7. Drag a link from the personal toolbar up to the Foo icon in the same window.
The Foo link sortof copies (instead of moving) to the Foo folder, so now the
link is in both the original Personal folder and the Foo folder.
8. Drag the link from the Foo folder in its own window back to the Personal
folder, and things go a little haywire. The link disappears from Foo, and it
takes up space in Personal, but does not draw.

Comment 6

16 years ago
What does it mean to "Dink down the personal toolbar?" On a browser window?

Comment 7

16 years ago
Sorry, 'dink' is the word I have seen for opening a disclosure triangle. By
'dink down' I mean that you click the little triangle for the personal toolbar
line in the manage bookmarks window so that its links are displayed below it.

Comment 8

16 years ago
At step 7 in comment 5, I find that the bookmark is moved, not copied using
FizzillaCFM/1.1-final on 10.1.5..

Comment 9

16 years ago
I'm using the 1.1 final for  OSX 10.2. I concur that the steps I described in comment #5 
now work fine.

However, using 1.1 final, I can get the bug this way...

1. Manage bookmarks
2. Create a Foo folder, and open it in its own window
3. Click the reveal triangle  on the personal toolbar (aka "dink it down")
4. Drag a link from dinked personal toolbar to Foo window -- the link  bounces back -- not 
great, but ok
5. Drag a link from dinked personal toolbar to Foo in same window. The link moves 
correctly. Dink open Foo, so you can see the link there and in its window, which is 
correct.
6. Drag the link from the Foo separate window over to the dinked personal toolbar -- this 
appears to copy instead of move which is probably wrong, and in any case, the data is 
probably now screwy. Moving the link between Foo and Personal in the same window 
works. The move from the Foo separate window is the precipitating step for later 
problems.
7. Drag the link from the dinked personal toolbar to the dinked Foo. The link disappears 
from Foo when it should appear a second time, and the link's row in personal is still 
there, but draws as a blank

Comment 10

16 years ago
Confirmed using FizzillaCFM/1.1-final on 10.1.5 to perform the steps in comment
9. (Nick, the actual term for "dink" is expand.)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 11

16 years ago
*** Bug 161334 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
Platform, OS ->all based on duplicate
Adding dependency based on duplicate
Depends on: 160019
OS: MacOS X → All
Hardware: Macintosh → All

Comment 13

16 years ago
I am still seeing this bug (using comment #9's procedure) in 1.2 release and
build 2002112521 (linux).

Besides that, I am also losing bookmarks with "File Bookmark".

Basically, it happens when:
- moving a folder with bookmarks to another folder, using "File Bookmark"
- the destination folder is expanded

And the problem:
- the bookmarks in the folder being moved are lost
- even though the bookmarks are lost, they may still be visible in the bookmark
manager, until mozilla is restarted. (they are not saved to bookmarks.html)


Steps to reproduce:
1) Open bookmark manager
2) Create a folder "Folder Root"
3) Create folders "Folder 1" and "Folder 2" under "Folder Root"
4) Create some bookmarks in "Folder 1" and "Folder 2"
5) Expand "Folder 2"
6) Right Click on "Folder 1", select "File Bookmark" and file it into "Folder 2"

   (at this point, bookmarks under "Folder 1" are lost (can be verified by
looking at bookmarks.html). but they may still be visible in bookmark manager.)

7) Restart Mozilla

   (now, all bookmarks under "Folder 1" disappeared.)


btw, anyone knows if this bug also appears in the 1.0 branch?
Keywords: mozilla1.3

Updated

16 years ago
Flags: blocking1.3a?

Updated

16 years ago
Flags: blocking1.3a? → blocking1.3a-

Updated

16 years ago
Flags: blocking1.3?

Updated

16 years ago
Flags: blocking1.3?

Updated

16 years ago
Blocks: 123929

Comment 14

15 years ago
Was this bug fixed when bug 160019 was fixed?

Why is this bug not referenced by bug 196756?

Comment 15

15 years ago
The problems described in comment #9 and comment #13 appear to be fixed on Linux
Build 2003040122.

Occasionally, the display screwed up (eg, after moving the bookmark/folder, the
"Name" of the bookmark is blank in the new position), but no dataloss occurs and
the display can be restored by closing and reopening the folder.

Updated

15 years ago
Blocks: 203343

Updated

15 years ago
No longer blocks: 123929

Comment 16

15 years ago
I had lost bookmarks on installation.  Tried clean install, then while Mozilla
was not running, I copied backup bookmarks into profile location.  Worked OK
till lost next day.  Does not lose bookmarks on restarting Mozilla or restarting
after power off; but loses them after startup on next day.   Actually, problem
seems to occur only if I have edited the bookmark list.  After moving bookmarks
to a folder in bookmark list, Mozilla deletes bookmark.htm upon quitting.

userAgent=Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5)
Gecko/20031007

Macintosh Blue & White G3, 400 Mhz
OS X 10.1.5, Build 5S66
Darwin Kernel Version 5.5: Thu May 30 14:51:26 PDT 2002;
root:xnu/xnu-201.42.3.obj~1/RELEASE_PPC

(originally entered under bug # 222714)

Comment 17

15 years ago
*** Bug 222714 has been marked as a duplicate of this bug. ***
Mass reassign of my non-Firefox bugs to ben_seamonkey@hotmail.com
Assignee: bugs → ben_seamonkey
Product: Browser → Seamonkey

Comment 19

14 years ago
Can anyone reproduce the problems with current builds?
Assignee: ben_seamonkey → p_ch
Keywords: mozilla1.3
QA Contact: claudius → bookmarks

Comment 20

13 years ago
no reponse and no statements that this is a problem for 2+ years
probably fixed by bug 160019

resolving WORSKFORME
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 21

13 years ago
Thought I resolved this... as I don't use Seamonkys often (ever) now and last
time I checked to see if a bug also existed I don't think I noticed this...
anyway thanks for closing Andrew.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.