Closed Bug 1596702 Opened 3 months ago Closed 3 months ago

In Dark Mode/Theme, unread messages are now hard to differentiate from tagged messages and inconsistent with the Thunderbird UI

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set

Tracking

(thunderbird_esr68 fixed, thunderbird71 fixed, thunderbird72 fixed)

RESOLVED FIXED
Thunderbird 72.0
Tracking Status
thunderbird_esr68 --- fixed
thunderbird71 --- fixed
thunderbird72 --- fixed

People

(Reporter: glennomzb, Assigned: Paenglab)

References

Details

Attachments

(4 files, 6 obsolete files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

Updated Thunderbird to 68.2.2, and use Dark Mode/Theme (in macOS Mojave)

Actual results:

In Dark Mode/Theme, Thunderbird now displays unread, untagged messages in the color blue, making it harder to differentiate tagged from untagged messages, and generally making the email list look overly busy, messy, and inconsistent with Light Mode/Theme and the long history of Thunderbird's UI.

Expected results:

In Dark Mode/Theme, unread messages should probably be white, and read messages probably a shade of gray (perhaps with a new option to easily change this in Preferences, if some users desire something other than this default setting). The difference between read and unread messages would still stand out clearly as white (bold) and gray (non-bold), while returning Thunderbird to a more consistent, cleaner, and clearer look overall - in part by ensuring that tagged messages stand out clearly regardless of their color.

I've read why the change to blue was made, but going with any color other than white/gray doesn't seem the best solution, IMO. Forcing unread messages to display blue makes them look like they have a tag color. This not only eliminates most shades of blue as useful tag color options, but it makes ALL tag colors stand out less clearly. Color should be reserved for tags, as it has long been (and as it still is in Light Mode). Thunderbird now has too much color, and all messages appear tagged. It's confusing and makes Thunderbird less efficient to use.

While there may be a workaround, it's too involved and cumbersome for most, requiring altering files and too many steps especially for users who auto-tag incoming (unread) messages. The above white/gray suggested fix might be a more practical, clean, and consistent solution for the default setting. Adding a new Preference setting could be a good fix for anyone who disagrees.

Sigh, you can't please everyone. Some people liked the blue. Maybe you want to chose your own colour by using a userChrome.css.

Flags: needinfo?(richard.marti)

(In reply to Jorg K (GMT+2) from comment #2)

Sigh, you can't please everyone. Some people liked the blue. Maybe you want to chose your own colour by using a userChrome.css.

True, but going colorless makes much more sense, is more consistent, and solves the original problem without causing a new one. Unlike the blue.

No, I don't want to use userChrome.css and have to go through a bunch of extra, non-user-friendly steps for each tag color which I use. What's wrong with adding the option to Preferences to change the New Mail color in Dark, if people want blue despite the issues it causes with tags? :)

Reduced contrast, the read messages in grey, isn't the way we should go. On your screenshot I can still good differ between unread and tagged messages.

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Flags: needinfo?(richard.marti)
Resolution: --- → WONTFIX

(In reply to Richard Marti (:Paenglab) from comment #4)

Reduced contrast, the read messages in grey, isn't the way we should go. On your screenshot I can still good differ between unread and tagged messages.

The right shade of gray seems the way Thunderbird should go, since it would be both clear and easy to read without adding the blue color messiness.

Please see the attached image, which shows what it could look like. It's a common design choice that works well.

As you can see, it's undeniably clearer overall, while retaining an unmistakable contrast between read and unread images, as well as a clear contrast between untagged messages (COLORLESS) and tagged messages (COLORS) — all while maintaining easy readability. It checks all the boxes, including that of consistency. It even makes users better-looking. (This claim untested.)

It's great that you find the blue color mixed with tag colors (including shades of blue) clear enough for your use. I think you should have that choice if you prefer it. But it's absolutely not clear to me, and it makes Thunderbird messier, less consistent, less efficient and less pleasant to use.

So, couldn't users be given a choice? Could this simply be an option in Preferences? That could please everyone, if doable. You could even use fuchsia, or smaragdine for unread messages!

But if that's too difficult to code, it seems white and light gray make more sense for read and unread messages, as shown. Introducing more color to the email list makes for a messier UI.

(BTW, is it not premature to mark this as "closed" and "wont fix"? Or is that how Bugzilla works? I'm new to it, since I've never had an issue. But if more people saw this open, perhaps they'd like the suggestion or have an even better solution?)

Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Here's what Thunderbird could look like with White & Lt Gray for untagged Unread & Read messages, without introducing a color, which are normally used for tags.

Alex and Richard, what do you think? Colour only for tagged messages?

Flags: needinfo?(richard.marti)
Flags: needinfo?(alessandro)

This is getting messier and messier, who thought that colouring the entire message row with a tag colour was a good idea? Turning the message list into an unreadable rainbow, uff.

Anyway, The blue highlight seems to not have been the best solution since, once again, there's an edge case where it doesn't work well.
I'm not really keen in spending time on this since I'm gonna nuke this entire list sooner or later and rebuild it with some sense and accessibility practices in mind.

The light grey for read messages might work in dark mode, but we shouldn't go darker than a #D4D4D4 to maintain a AAA readability on small text.
I'm open to suggestions and ideas.

Richard, what do you think?

Flags: needinfo?(alessandro)

Just to facilitate discussion with some visuals, I'll post 6 variations below, ranging from 87% gray to 69% gray. Note the above-mentioned D4D4D4 is 83% gray.

Attached image Idea 1a - #DEDEDE - 87% GRAY (obsolete) —

1st of 6 variants of "Read" message color, just to facilitate discussion: #DEDEDE - 87% GRAY

Attached image Idea 1 - #D4D4D4 - 83% GRAY.jpg (obsolete) —

2nd of 6 variants of "Read" message color, just to facilitate discussion: #D4D4D4 - 83% GRAY

Attached image Idea 2 - #C7C7C7 - 78% GRAY.jpg (obsolete) —

3rd of 6 variants of "Read" message color, just to facilitate discussion: #C7C7C7 - 78% GRAY

Attached image Idea 3 - #BFBFBF - 75% GRAY.jpg (obsolete) —

4th of 6 variants of "Read" message color, just to facilitate discussion: #BFBFBF - 75% GRAY

Attached image Idea 4 - #BABABA - 73% GRAY.jpg (obsolete) —

5th of 6 variants of "Read" message color, just to facilitate discussion: #BABABA - 73% GRAY

Attached image Idea 5 - #B0B0B0 - 69% GRAY.jpg (obsolete) —

6th of 6 variants of "Read" message color, just to facilitate discussion: #B0B0B0 - 69% GRAY

Drat, could someone kindly delete my above 6 images? I see that even with the embedded sRGB color profile, the background gray isn't accurate, making my sample images useless. :) I can fix later, unless folks just want to test variants for themselves.

Okay, I use #d4d4d5 on all trees as normal text colour to don't make the threadTree faint against the other trees.

Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(richard.marti)
Attachment #9110182 - Flags: review?(alessandro)

Fixed it. Here are 6 variations of gray for the "read messages" color, all shown in one image file.
Just to help folks consider

Attachment #9110088 - Attachment is obsolete: true
Attachment #9110089 - Attachment is obsolete: true
Attachment #9110092 - Attachment is obsolete: true
Attachment #9110093 - Attachment is obsolete: true
Attachment #9110094 - Attachment is obsolete: true
Attachment #9110095 - Attachment is obsolete: true
Comment on attachment 9110182 [details] [diff] [review]
1596702-dark-unread-color.patch

Review of attachment 9110182 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good to me.
The readability is good and the accessibility contrast is still AAA.
r+
Attachment #9110182 - Flags: review?(alessandro) → review+
Attachment #9110182 - Flags: approval-comm-esr68?
Attachment #9110182 - Flags: approval-comm-beta?

(In reply to Alessandro Castellani (:aleca) from comment #19)

Review of attachment 9110182 [details] [diff] [review]:

This looks good to me.
The readability is good and the accessibility contrast is still AAA.

Ditto.

Some users might want a very slightly darker gray for clearer differentiation from white "unread" messages, but to me D4D4D5 looks clear enough and strikes a nice balance.

Attachment #9110182 - Flags: approval-comm-beta? → approval-comm-beta+

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/1a8b28dd2a97
Dark theme: don't use blue for unread messages but make read messages grey. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 3 months ago3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 72.0
Attachment #9110182 - Flags: approval-comm-esr68? → approval-comm-esr68+
Regressions: 1604406
Duplicate of this bug: 1607480
You need to log in before you can comment on or make changes to this bug.