Closed Bug 1597062 Opened 11 months ago Closed 11 months ago

Port |Bug 581932 - Keyboard shortcuts are disabled after deleting a message and next is a thread when message pane has focus|

Categories

(SeaMonkey :: MailNews: Message Display, task)

task
Not set
normal

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 fixed, seamonkey2.57esr fixed)

RESOLVED FIXED
seamonkey2.69
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- fixed
seamonkey2.57esr --- fixed

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

Details

Attachments

(1 file)

This port the changes from Bug 581932 which:

  • Adds focusedPane to gFolderDisplay
  • Switches code to use focusedPane instead of WhichPaneHasFocus()
  • Removes WhichPaneHasFocus() function

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: None
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: None

Attachment #9109230 - Flags: review?(frgrahl)
Attachment #9109230 - Flags: approval-comm-release?
Attachment #9109230 - Flags: approval-comm-esr60?
Blocks: 1597073
Comment on attachment 9109230 [details] [diff] [review]
focusedPane patch

LGTM
Attachment #9109230 - Flags: review?(frgrahl)
Attachment #9109230 - Flags: review+
Attachment #9109230 - Flags: approval-comm-release?
Attachment #9109230 - Flags: approval-comm-release+
Attachment #9109230 - Flags: approval-comm-esr60?
Attachment #9109230 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/e3ca458febd1
Port |Bug 581932 - Keyboard shortcuts are disabled after deleting a message and next is a thread when message pane has focus|. r=frg

Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.