Closed Bug 1597438 Opened 1 year ago Closed 8 months ago

Fix uses of nsGlobalWindowOuter::SetFullscreenInternal in dom/base/nsGlobalWindowOuter.cpp

Categories

(Core :: DOM: Navigation, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1597439
Fission Milestone M6

People

(Reporter: djvj, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [rm-docshell-tree-item:hard])

In file dom/base/nsGlobalWindowOuter.cpp

Forwards SetFullScreenInternal to root window using DocShell Tree.

Needs to change for case when root window is out-of-process (IPC).

Change to using BrowsingContext to find root or issue IPC.

Infrequently called functionality so an IPC should be fine.

Kannan says replacing nsIDocShellTreeItem calls should block enabling Fission in Nightly (M6).

Fission Milestone: --- → M6
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1597439
You need to log in before you can comment on or make changes to this bug.