Closed Bug 1597439 Opened 1 year ago Closed 2 months ago

Update Fullscreen with fission support

Categories

(Core :: DOM: Navigation, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Fission Milestone M6c

People

(Reporter: djvj, Assigned: smacleod)

References

(Blocks 3 open bugs)

Details

(Whiteboard: will confirm with new tests, ETA: 9/18 [rm-docshell-tree-item:sync-state])

In file dom/base/nsGlobalWindowOuter.cpp

Checks if mDocShell is root item, and if so returns full-screen flag from this one.

Otherwise retrieves value from root docshell window.

Code should be changed to retreive this value from WindowContext, presumably hanging off of the appropriate BrowsingContext.

Kannan says replacing nsIDocShellTreeItem calls should block enabling Fission in Nightly (M6).

Fission Milestone: --- → M6
Priority: -- → P3

We should look into this as part of generally ensuring that the Fullscreen API is supported when Fission is enabled. This may be somewhat related to bug 1606660.

Flags: needinfo?(xidorn+moz)
Summary: Fix uses of nsGlobalWindowOuter::Fullscreen in dom/base/nsGlobalWindowOuter.cpp → Update Fullscreen with fission support
Flags: needinfo?(xidorn+moz)
Duplicate of this bug: 1597438

Auditing whether this use of nsIDocShellTreeItem breaks when Fission is enabled blocks Fission Nightly.

Fission Milestone: M6 → M6b
Depends on: 1646491
Assignee: nobody → alchen
Status: NEW → ASSIGNED
Blocks: 1619370
Assignee: alchen → smacleod
Whiteboard: [rm-docshell-tree-item:sync-state] → ETA: 9/10 [rm-docshell-tree-item:sync-state]
Whiteboard: ETA: 9/10 [rm-docshell-tree-item:sync-state] → will confirm with new tests, ETA: 9/18 [rm-docshell-tree-item:sync-state]
Depends on: 1662702
Depends on: 1665941

smacleod has confirmed basic fullscreen functionality with OOP iframes works, and he's writing new tests in bug 1665941. This doesn't block M6b anymore.

Fission Milestone: M6b → M6c

Closing out as all blockers have been fixed.

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.