Closed Bug 1597579 Opened 3 months ago Closed 3 months ago

Disable the bookmarks mirror in 71 release by default

Categories

(Firefox :: Sync, task)

task
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox71 + fixed
firefox72 --- wontfix

People

(Reporter: Lina, Assigned: Lina)

References

Details

Attachments

(1 file)

[Tracking Requested - why for this release]:

We accidentally used the wrong pref name for the new bookmark sync gradual rollout, so it didn't have any effect. We'll roll out to 25% of release tomorrow, but there isn't a lot of time left in the 70 cycle, meaning any bugs we see will remain unfixed in 71—and will need to be fixed in 73 and uplifted to 72.

I think it would be safest to:

  • Back bug 1588005 out of Beta 71 only. Keep it in Nightly 72, so that it'll still be pref'd on by default when we merge in a couple of weeks.
  • Change the gradual rollout experiment to target 70 and 71.
  • Monitor our dashboard, and fix any bugs as they come up.

How does that sound to everyone? There's no rush to get new bookmark sync out—slipping one release won't make a big difference, and I think it's worth waiting to make sure we aren't messing up our users' bookmarks.

Though, since it's a Boolean pref...can we use Normandy to flip it back to false for 100% of 70/71 users if things go wrong? That might be better than backing bug 1588005 out, and basically (if all goes well!) enrolling 100% of 71 users for the full cycle.

We could probably find a way to do that with Normandy, but I don't think it's a good idea. I think we'll have a lot better success by backing bug 1588005 of 71, and letting it ride in 72.

The reason for this is that the Normandy actions assume one of two things either (a) the change is permanent and the base system will "catch up" eventually, or (b) the change is an experiment, presented to users differently. We don't have a good way to make large scale, temporary change without marking it as an experiment.

Cool, thanks Mythmon! Let me push a backout patch now.

So, if the rollout goes well in 70, could we expand the experiment to also target 71?

Flags: needinfo?(mcooper)

We have two weeks left until 71 release, and haven't rolled out new
bookmark sync to everyone yet. Let's disable this in 71 by default
(but have it ride the train in 72+), and flip it on for everyone in
70 and 71 using Normandy.

Comment on attachment 9110071 [details]
Bug 1597579 - Back bug 1588005 out of Beta only.

Beta/Release Uplift Approval Request

  • User impact if declined: Not enough time to validate the rollout of new bookmark sync in 70, or fix new issues in 71. New bookmark sync will still ride the train in 72, and gradually rolled out in 70 and 71.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Unflipping a pref in release and late Betas, to give the feature more time to bake.
  • String changes made/needed: None
Attachment #9110071 - Flags: approval-mozilla-beta?

(This backout should only land on m-b, not m-c).

So, if the rollout goes well in 70, could we expand the experiment to also target 71?

I think it makes sense to extend this into 71, so that users have an uninterrupted experience as much as possible. I can make this change at the next shield change window.

Flags: needinfo?(mcooper)

That would be perfect! Thank you so much.

I'll take this in our last beta tomorrow.

Comment on attachment 9110071 [details]
Bug 1597579 - Back bug 1588005 out of Beta only.

Uplift approved for 71 beta 12, thanks.

Attachment #9110071 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.