Closed Bug 1597787 Opened 10 months ago Closed 10 months ago

Send Principals directly through JSWindowActors rather than serializing / deserializing them

Categories

(Firefox :: General, task, P1)

task

Tracking

()

RESOLVED FIXED
Firefox 72
Fission Milestone M5
Tracking Status
firefox72 --- fixed

People

(Reporter: mconley, Assigned: mconley)

References

Details

Attachments

(1 file)

I had filed bug 1557852 when working on bug 1505909, since it seemed as if I couldn't send Principals from one JSWindowActor to another.

Have recently retried it though, it appears to work now. So I'm not sure what was going wrong before.

Anyhow, there are a few places where I see that we're serializing / deserializing Principals needlessly across actors. This bug is for cleaning that up.

Duplicate of this bug: 1597788
Priority: -- → P1
Status: NEW → ASSIGNED
Fission Milestone: --- → M5
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3dabf00ac319
Send principals directly across JSWindowActors rather than serializing / deserializing them. r=NeilDeakin
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
You need to log in before you can comment on or make changes to this bug.