Closed Bug 1597940 Opened 4 months ago Closed 4 months ago

Perma gv-docs Halting on failure running 'android', 'geckoview-docs', '--archive', '--upload', 'mozilla/geckoview', '--upload-branch', 'gh-pages--javadoc-path', 'javadoc/{project}', '--upload-message', 'Update {project} documentation to rev {revision}']

Categories

(GeckoView :: General, defect, P5)

Unspecified
All
defect

Tracking

(firefox72 fixed)

RESOLVED FIXED
mozilla72
Tracking Status
firefox72 --- fixed

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Regression)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: csabou [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=277137433&repo=mozilla-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/Nzhwy4yZSTqL-tcEJ-PF5w/runs/0/artifacts/public/logs/live_backing.log


[task 2019-11-20T09:58:26.725Z] 09:58:26 INFO - /builds/worker/workspace/build/src/obj-firefox/sccache-stats.json does not exist; not loading sccache stats
[task 2019-11-20T09:58:26.725Z] 09:58:26 INFO - PERFHERDER_DATA: {"framework": {"name": "build_metrics"}, "suites": [{"subtests": [{"name": "configure", "value": 7.87103009223938}, {"name": "pre-export", "value": 0.3391990661621094}, {"name": "export", "value": 39.90656089782715}, {"name": "misc", "value": 0.8864328861236572}, {"name": "libs", "value": 6.067630052566528}, {"name": "android-stage-package", "value": 2.9982011318206787}, {"name": "android-archive-geckoview", "value": 45.81569695472717}, {"name": "tools", "value": 0.08836102485656738}], "extraOptions": ["taskcluster-c5d.4xlarge", "android-geckoview-docs"], "name": "build times", "value": 104.1351568698883}]}
[task 2019-11-20T09:58:26.726Z] 09:58:26 INFO - Running command: ['/builds/worker/workspace/build/src/obj-x86_64-pc-linux-gnu/_virtualenvs/init/bin/python', 'mach', '--log-no-times', 'android', 'geckoview-docs', '--archive', '--upload', 'mozilla/geckoview', '--upload-branch', 'gh-pages--javadoc-path', 'javadoc/{project}', '--upload-message', 'Update {project} documentation to rev {revision}'] in /builds/worker/workspace/build/src
[task 2019-11-20T09:58:26.726Z] 09:58:26 INFO - Copy/paste: /builds/worker/workspace/build/src/obj-x86_64-pc-linux-gnu/_virtualenvs/init/bin/python mach --log-no-times android geckoview-docs --archive --upload mozilla/geckoview --upload-branch gh-pages--javadoc-path javadoc/{project} --upload-message "Update {project} documentation to rev {revision}"
[task 2019-11-20T09:58:26.726Z] 09:58:26 INFO - Using env: (same as previous command)
[task 2019-11-20T09:58:26.941Z] 09:58:26 INFO - It looks like you passed an unrecognized argument into mach.
[task 2019-11-20T09:58:26.941Z] 09:58:26 INFO - The android command does not accept the arguments: javadoc/{project}
[task 2019-11-20T09:58:26.951Z] 09:58:26 ERROR - Return code: 1
[task 2019-11-20T09:58:26.951Z] 09:58:26 ERROR - 1 not in success codes: [0]
[task 2019-11-20T09:58:26.951Z] 09:58:26 WARNING - setting return code to 2

Flags: needinfo?(etoop)
Flags: needinfo?(agi)
Regressed by: 1585661

An error in updating the 64_geckoview_docs.py file (missing comma) caused perma fail of gv-docs task.

Pushed by etoop@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/37771c6a4bb3
Add missing comma causing gv-docs task to fail r=geckoview-reviewers,esawin
Flags: needinfo?(agi)
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
Flags: needinfo?(etoop)
You need to log in before you can comment on or make changes to this bug.