Closed Bug 1598062 Opened 3 months ago Closed 3 months ago

Turn abuseReport.amWebAPI on by default on all channels

Categories

(Toolkit :: Add-ons Manager, task, P1)

task

Tracking

()

VERIFIED FIXED
mozilla72
Tracking Status
firefox71 + verified
firefox72 --- verified

People

(Reporter: rpl, Assigned: rpl)

References

Details

Attachments

(1 file)

Now that Bug 1580561 has been QA verified (on both 71 Beta and Nightly), we should proceed to enabling it by default on all channel.

We should also request an uplift to beta for this patch if we want to proceed to enabling the feature on 71 as originally planned.

Assignee: nobody → lgreco
Blocks: 1561022
Status: NEW → ASSIGNED
Depends on: 1580561
Priority: -- → P1
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/72d49fd8c033
Turn abuseReport.amWebAPI on by default on all channels. r=mixedpuppy
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72

Verified as fixed in FF 72.0a1 (2019-11-21).

Status: RESOLVED → VERIFIED

Comment on attachment 9110325 [details]
Bug 1598062 - Turn abuseReport.amWebAPI on by default on all channels. r?mixedpuppy!

Beta/Release Uplift Approval Request

  • User impact if declined: Without this patch AMO cannot "hand-off" the abuse reports triggered from the website to the Firefox integrated abuse report panel for users on Firefox 71 (because the pref wouldn't be yet set to true and the feature would stay disabled).
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Same STR used by QA to verify it on Nightly.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The patch is only flipping the value of an existing about:config preference to enable the mozAddonManager.reportAbuse API method by default.
    The feature locked behind this pref is fairly isolated and enabling it shouldn't impact on any other part of Firefox.
    The underlying feature has been QA verified on both 71 Beta and 72 Nightly, all the issues identified during the QA verification have been fixed and the fix uplifted to beta and QA verified it explicitly.
    The feature and the most of the fixes applied have been covered by automated tests.
  • String changes made/needed:
Attachment #9110325 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9110325 [details]
Bug 1598062 - Turn abuseReport.amWebAPI on by default on all channels. r?mixedpuppy!

Low risk, P1, Uplift approved for the beta branch before RC.

Attachment #9110325 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Verified as Fixed on the latest Beta (71.0/20191125204040).

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.